summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-27 03:22:08 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-03-28 00:21:06 +0200
commit80d011f408fa50ac5733fc2f629dc55c2abb19ee (patch)
tree970914a3d16066b33762d3ec362c88a9efa75ace /dev-libs
parentdev-libs/intel-metrics-library: initial import (diff)
downloadgentoo-80d011f408fa50ac5733fc2f629dc55c2abb19ee.tar.gz
gentoo-80d011f408fa50ac5733fc2f629dc55c2abb19ee.tar.bz2
gentoo-80d011f408fa50ac5733fc2f629dc55c2abb19ee.zip
dev-libs/intel-compute-runtime: add 22.11.22682
Closes: https://bugs.gentoo.org/817146 Closes: https://github.com/gentoo/gentoo/pull/23595 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.11.22682.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 6dafd299d6dc..ada3d0bc4175 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,2 +1,3 @@
DIST intel-compute-runtime-21.46.21636.tar.gz 4878855 BLAKE2B 0ada296b36567038b2abeba50c2dae6604981f00cdfc0d5d9d197c793534c887fa1d321ced34b37cf6760bdc9e2b8769cdc24fe3884036b78b983660c90b1ee7 SHA512 a63436d049737b955f0e23bbfc78684f665f3d1a668120e803165839792144154f3f42a52c6533611711592ba6e41408d81196a61e318746b1dae1392d1d29ac
DIST intel-compute-runtime-21.50.21939.tar.gz 5106368 BLAKE2B 3a8613c7178975bf930f0ccbed06d31952f05c8316e7735db759a7bcc8b81b5bd3040af62bae6e63fc9781ce2e6e8f035751cd6696b4c7cfbb6025f3d4fcfd8b SHA512 cabcb0fb9816ca8e6b93fa069c73926ccdaf3803c073b11f62477f80d38af49a7b4e814765a40e3daae50a6159560872c5b5123f64e68a570556c80d47a120c9
+DIST intel-compute-runtime-22.11.22682.tar.gz 5220769 BLAKE2B c5cacdb0140fe9247353b9922a2e401a866d73ea9d4fa6a4312c984d4ba0751ff60d58f15b49003020d88bef13808113ba8ca84239c140fa7c26edcd401c0d9c SHA512 0e4007b152a20e85d40e71d68144a8dab1be536800650fbd1c3f5e23a0731c733d7dfa943d7ea4e1f19548313b12474bd5b9426ef7f2057a9b106a0fc9a1762a
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.11.22682.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.11.22682.ebuild
new file mode 100644
index 000000000000..1d868e365abd
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.11.22682.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.10409
+ >=dev-util/intel-graphics-system-controller-0.2.4
+ >=media-libs/gmmlib-22.0.2:=
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.7.9 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+# for Khronos OpenGL headers
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-22.11.22682-metrics.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ # -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+
+ -Wno-dev
+ )
+
+ cmake_src_configure
+}