summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2019-04-16 23:27:43 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2019-04-16 23:28:18 +0300
commit812f60f2b8ceea08fbf418c73e49059d0ee6a21f (patch)
tree5e2ee92c123ed763643aa91906a73a065c8aaa8d /dev-libs
parentdev-libs/xmlsec: version bump (diff)
downloadgentoo-812f60f2b8ceea08fbf418c73e49059d0ee6a21f.tar.gz
gentoo-812f60f2b8ceea08fbf418c73e49059d0ee6a21f.tar.bz2
gentoo-812f60f2b8ceea08fbf418c73e49059d0ee6a21f.zip
dev-libs/botan: fix >=dev-libs/boost-1.70.0
Closes: https://bugs.gentoo.org/show_bug.cgi?id=683376 Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/botan/botan-2.9.0.ebuild4
-rwxr-xr-xdev-libs/botan/files/botan-2.9.0-build.patch63
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/botan/botan-2.9.0.ebuild b/dev-libs/botan/botan-2.9.0.ebuild
index 8f92905d738a..4f995a89686a 100644
--- a/dev-libs/botan/botan-2.9.0.ebuild
+++ b/dev-libs/botan/botan-2.9.0.ebuild
@@ -34,6 +34,10 @@ RDEPEND="${DEPEND}
BDEPEND="dev-lang/python:*
doc? ( dev-python/sphinx )"
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
src_configure() {
local disable_modules=()
use boost || disable_modules+=( "boost" )
diff --git a/dev-libs/botan/files/botan-2.9.0-build.patch b/dev-libs/botan/files/botan-2.9.0-build.patch
new file mode 100755
index 000000000000..6208ffdbf0ad
--- /dev/null
+++ b/dev-libs/botan/files/botan-2.9.0-build.patch
@@ -0,0 +1,63 @@
+From 86df247e4f090f984e050962ed5a4a536ec63b33 Mon Sep 17 00:00:00 2001
+From: Ralf van der Enden <Ralf.vanderEnden@deltares.nl>
+Date: Fri, 5 Apr 2019 14:58:14 +0200
+Subject: [PATCH] boost 1.70 compatibility
+
+Fixes issue #82
+---
+ src/cli/tls_http_server.cpp | 8 +++++++-
+ src/cli/tls_proxy.cpp | 8 +++++++-
+ 2 files changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/src/cli/tls_http_server.cpp b/src/cli/tls_http_server.cpp
+index cc59a71c33..0a6428cd65 100644
+--- a/src/cli/tls_http_server.cpp
++++ b/src/cli/tls_http_server.cpp
+@@ -41,6 +41,12 @@
+
+ #include "credentials.h"
+
++#if BOOST_VERSION >= 107000
++#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
++#else
++#define GET_IO_SERVICE(s) ((s).get_io_service())
++#endif
++
+ namespace Botan_CLI {
+
+ namespace {
+@@ -435,7 +441,7 @@ class TLS_Asio_HTTP_Server final
+ session::pointer make_session()
+ {
+ return session::create(
+- m_acceptor.get_io_service(),
++ GET_IO_SERVICE(m_acceptor),
+ m_session_manager,
+ m_creds,
+ m_policy);
+diff --git a/src/cli/tls_proxy.cpp b/src/cli/tls_proxy.cpp
+index 49ffbe3766..42ce156b12 100644
+--- a/src/cli/tls_proxy.cpp
++++ b/src/cli/tls_proxy.cpp
+@@ -33,6 +33,12 @@
+
+ #include "credentials.h"
+
++#if BOOST_VERSION >= 107000
++#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
++#else
++#define GET_IO_SERVICE(s) ((s).get_io_service())
++#endif
++
+ namespace Botan_CLI {
+
+ namespace {
+@@ -370,7 +376,7 @@ class tls_proxy_server final
+ session::pointer make_session()
+ {
+ return session::create(
+- m_acceptor.get_io_service(),
++ GET_IO_SERVICE(m_acceptor),
+ m_session_manager,
+ m_creds,
+ m_policy,