summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-23 00:22:25 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-23 00:22:25 +0200
commit84ba80bca06d5613d7e9e6e9f28bbdc2ec8052c2 (patch)
tree4008edd4cbde8df2e35661430554568741697d0a /dev-libs
parentdev-util/intel-graphics-compiler: add 1.0.10988 (diff)
downloadgentoo-84ba80bca06d5613d7e9e6e9f28bbdc2ec8052c2.tar.gz
gentoo-84ba80bca06d5613d7e9e6e9f28bbdc2ec8052c2.tar.bz2
gentoo-84ba80bca06d5613d7e9e6e9f28bbdc2ec8052c2.zip
dev-libs/intel-compute-runtime: add 22.16.22992
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 5f09d2a0b57f..e4744158e2f4 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -3,3 +3,4 @@ DIST intel-compute-runtime-22.12.22749.tar.gz 5234659 BLAKE2B 162c4781561a131af5
DIST intel-compute-runtime-22.13.22789.tar.gz 5252140 BLAKE2B 81fe85e75b1f6257771950dd2716e48f8db61dbe62f747c13ed00be7385c9e6a2f2cd2a5d50cf4253962d13bd1fdb4449a5e646fe3a8b10af228f746b9880210 SHA512 e4d22d8f73463300424b2df9a9634f0b5ac341131de33e57d46ffd52ce0b3fbdbf62cf591876d2143ca14caeba42ec95f5aef201eb9895e5d36b2279b15e661c
DIST intel-compute-runtime-22.14.22890.tar.gz 5290076 BLAKE2B 9a6ec8ed142a183d270006726d34492adea989bc2db9eff53046f4c247f7d5089e4cbb6448513b54eeaf7079f990f9a3b6d31cca53459bc2fcd1ced5d2b1bea1 SHA512 78c195832a0f55ff0bf64519234a5f70f1459263000804db1cc73a72c4c07e12c540a9fa0a574bf382713deb132be50b6e6eb7b4abfd264f707889bf02fc1af7
DIST intel-compute-runtime-22.15.22905.tar.gz 5301399 BLAKE2B fd2d2e6e284cceba4b2de5d56cea537784ae774b047ed1b67f17f92acbc821579ab619e509aa67de9802bb94bdae215372e64575c2590b24d69a0c9c10d63b66 SHA512 9976d762e4851a48bb72e4c59ec4c557a02b34c959bd5c602eb31232d473501e6ea6fe925385a579df6a120537b1efde2c0bdc409c94b2b2072a14761b293973
+DIST intel-compute-runtime-22.16.22992.tar.gz 5334525 BLAKE2B e2fd74084cddc8163eff46cf267c33206c240b8e7c513d2408dabcc0290182fcb5ce7a8909dca93cbb6fd95c2130448498845602590ff59487508b7adcb2bd65 SHA512 7a133a97f437dfe62559097e41583db60e54af6937cfcb3613f4c54340919a0ee0136cfcea1fb6005341021a9bb139c40be8d237afa2a246accd0af1a20dd297
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992.ebuild
new file mode 100644
index 000000000000..eca15c13bd28
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND=">=media-libs/gmmlib-22.0.2:="
+
+DEPEND="
+ ${DEPEND}
+ dev-libs/intel-metrics-library
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.10713
+ >=dev-util/intel-graphics-system-controller-0.2.4
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.7.15 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+
+ -Wno-dev
+ )
+
+ cmake_src_configure
+}