summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-06 10:37:09 -0500
committerMatt Turner <mattst88@gentoo.org>2022-11-06 13:25:50 -0500
commit84d63be6ccca7b144552b6dcf5df592c2169882f (patch)
treee46c91afcb3ba053c66990d96e02fd02b4adb5d3 /dev-libs
parentdev-libs/appstream-glib: Version bump to 0.8.2 (diff)
downloadgentoo-84d63be6ccca7b144552b6dcf5df592c2169882f.tar.gz
gentoo-84d63be6ccca7b144552b6dcf5df592c2169882f.tar.bz2
gentoo-84d63be6ccca7b144552b6dcf5df592c2169882f.zip
dev-libs/wayland-protocols: Version bump to 1.28
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index c7dbbb71cd29..d037ae352970 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,2 +1,3 @@
DIST wayland-protocols-1.26.tar.xz 81028 BLAKE2B 0813b8117c48b965560c3f112f67fa209f29b0c40fab2b46f46ccae227d68902277cce06281a6bd938fb3c2186e0cf4ea3670ed6d3b48b51ed655012bb1452ce SHA512 fa9c3963b548197461c8c0b9e16ebbf9cfa5b60053fc17f51b41e63a55b8c5420dd7e42313f93946b438ab47f04e1cd17bc92aae9e1074b47177dc7ce7042167
DIST wayland-protocols-1.27.tar.xz 82604 BLAKE2B ae1c19dffcf255c88e6d646f321ec194639500994f9e5a2759bd7081dc16872777c993d35d81000796e3e5044dc62f169c9b2fe89de081fd395eaaf09e6206e2 SHA512 c0a49bc46c663c9f602998dfe2e184c09756790fbcc7acbc2bf9d9cf8f7d6dcdd00259b768222a30e5d134e6f97f7f4faf252947b544e8b32f53278b70da0390
+DIST wayland-protocols-1.28.tar.xz 84116 BLAKE2B 2b911b471ea61e34da5f0c8eb1bc67e0786261411123bffb02bfcea4e0c5e85b2ca1e8cf3f8f55fc92aae0365c30caed42e3c6037df46ce581f27952f6e38a24 SHA512 092454c6a7e5cc47729de49e9061fb91dfdc5610859e17c495642806ca14dcfb3850a5d3a7459ddb70b2adb08d2590d4b0f92c3a97600e48598682d59adb102f
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild
new file mode 100644
index 000000000000..4eff41270cb0
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}