summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-22 12:09:08 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-22 12:09:08 -0400
commit8e9e8ff169019c6c772cfeae7a17bc3b66361c5e (patch)
tree60547e7cd8a2f4c4aa7292af1dd20c5bc02a1788 /dev-libs
parentapp-misc/screen: arm/ppc/ppc64 stable wrt bug #655490 (diff)
downloadgentoo-8e9e8ff169019c6c772cfeae7a17bc3b66361c5e.tar.gz
gentoo-8e9e8ff169019c6c772cfeae7a17bc3b66361c5e.tar.bz2
gentoo-8e9e8ff169019c6c772cfeae7a17bc3b66361c5e.zip
dev-libs/satyr: new package
Package is to support the revbump of dev-libs/libreport. Closes: https://bugs.gentoo.org/619538 Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/satyr/Manifest1
-rw-r--r--dev-libs/satyr/metadata.xml8
-rw-r--r--dev-libs/satyr/satyr-0.26.ebuild45
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/satyr/Manifest b/dev-libs/satyr/Manifest
new file mode 100644
index 000000000000..cb6c8364e06c
--- /dev/null
+++ b/dev-libs/satyr/Manifest
@@ -0,0 +1 @@
+DIST satyr-0.26.tar.gz 434820 BLAKE2B 4463c69e6ac2eb8237f599bfeed308265a906c6e3efa154b14eb6ee7acdc65580da9baf5ecb99e4efa4f8c00f7656ff2a747e607f2293b12a513ed680986fe08 SHA512 45dfc42e05e93fa0417c8c5d6811097cabaa0f4dcfb79df13d3840d789cfd41c84382ae84882ca120b1a3120987123a306656324cf39f306046a5d30547db656
diff --git a/dev-libs/satyr/metadata.xml b/dev-libs/satyr/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/dev-libs/satyr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/satyr/satyr-0.26.ebuild b/dev-libs/satyr/satyr-0.26.ebuild
new file mode 100644
index 000000000000..400a2a442d4a
--- /dev/null
+++ b/dev-libs/satyr/satyr-0.26.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools python-r1 toolchain-funcs
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/elfutils-0.158
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needs to be run before full autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-rpm
+ # Build breaks without and we aren't supporting Python2 anyway
+ --without-python2
+ $(usex python "--with-python3" "--without-python3")
+ )
+
+ econf "${myargs[@]}"
+}