summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 19:48:14 +0100
committerSam James <sam@gentoo.org>2022-04-17 19:59:40 +0100
commit8ed18b0753edd9cd217b71ca804c891e1b8a4e45 (patch)
tree2a59a334422be50c54d8b1b30630d7e0fa7ba988 /dev-libs
parentdev-libs/fstrm: drop 0.6.0 (diff)
downloadgentoo-8ed18b0753edd9cd217b71ca804c891e1b8a4e45.tar.gz
gentoo-8ed18b0753edd9cd217b71ca804c891e1b8a4e45.tar.bz2
gentoo-8ed18b0753edd9cd217b71ca804c891e1b8a4e45.zip
dev-libs/keystone: drop 0.9.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/keystone/keystone-0.9.2.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/dev-libs/keystone/keystone-0.9.2.ebuild b/dev-libs/keystone/keystone-0.9.2.ebuild
deleted file mode 100644
index 7ef25cfa1b43..000000000000
--- a/dev-libs/keystone/keystone-0.9.2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LLVM_MAX_SLOT=12
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{8,9,10} )
-
-inherit cmake distutils-r1 llvm
-
-DESCRIPTION="assembly/assembler framework + bindings"
-HOMEPAGE="https://www.keystone-engine.org/"
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/keystone-engine/keystone.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/keystone-engine/keystone/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-# Keep in sync with llvm/CMakeLists.txt, subset of sys-devel/llvm
-ALL_LLVM_TARGETS=( AArch64 ARM Hexagon Mips PowerPC Sparc SystemZ X86 )
-ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
-LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
-
-IUSE="python ${ALL_LLVM_TARGETS[*]}"
-
-RDEPEND="
- <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):=[${LLVM_TARGET_USEDEPS// /,}]
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE="
- || ( ${ALL_LLVM_TARGETS[*]} )
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-S=${WORKDIR}/${P/_rc/-rc}
-
-wrap_python() {
- if use python; then
- pushd bindings/python >/dev/null || die
- distutils-r1_${1} "$@"
- popd >/dev/null || die
- fi
-}
-
-src_prepare() {
- default
- sed -i '/NOT uppercase_CMAKE_BUILD_TYPE MATCHES/ s/DEBUG/GENTOO|DEBUG/' \
- llvm/CMakeLists.txt || die
- cmake_src_prepare
- wrap_python ${FUNCNAME}
-}
-
-src_configure() {
- local libdir="$(get_libdir)"
- local mycmakeargs=(
- -DCMAKE_CONFIGURATION_TYPES="Gentoo"
- -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
- -DBUILD_SHARED_LIBS=ON
- -DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
- -DLLVM_HOST_TRIPLE="${CHOST}"
- )
-
- cmake_src_configure
- wrap_python ${FUNCNAME}
-}
-
-src_compile() {
- cmake_src_compile
- wrap_python ${FUNCNAME}
-}
-
-src_install() {
- cmake_src_install
- wrap_python ${FUNCNAME}
-}