summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-19 23:28:37 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-19 23:28:54 +0200
commit90ff54821da146478e1c19f2945789dcd4f177fc (patch)
tree74f48f90ddd5ff766a3d8b2e9ae00d6caf99ed09 /dev-libs
parentnet-analyzer/tcpdump: amd64 stable #626462 (diff)
downloadgentoo-90ff54821da146478e1c19f2945789dcd4f177fc.tar.gz
gentoo-90ff54821da146478e1c19f2945789dcd4f177fc.tar.bz2
gentoo-90ff54821da146478e1c19f2945789dcd4f177fc.zip
dev-libs/libexplain: add a missing dependency.
This commit bumps the ebuild to EAPI version 6 and adds a missing dependency on sys-apps/acl. Gentoo-Bug: https://bugs.gentoo.org/579268 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libexplain/files/libexplain-0.45-configure.patch4
-rw-r--r--dev-libs/libexplain/libexplain-1.4-r1.ebuild50
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-libs/libexplain/files/libexplain-0.45-configure.patch b/dev-libs/libexplain/files/libexplain-0.45-configure.patch
index e82d05da534f..0f031fb8d348 100644
--- a/dev-libs/libexplain/files/libexplain-0.45-configure.patch
+++ b/dev-libs/libexplain/files/libexplain-0.45-configure.patch
@@ -1,5 +1,5 @@
---- libexplain-0.45.D001.orig/configure.ac
-+++ libexplain-0.45.D001/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -26,6 +26,10 @@
AC_PROG_RANLIB
AC_PROG_YACC
diff --git a/dev-libs/libexplain/libexplain-1.4-r1.ebuild b/dev-libs/libexplain/libexplain-1.4-r1.ebuild
new file mode 100644
index 000000000000..94aaf264a854
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-1.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3 LGPL-3"
+IUSE="static-libs"
+
+DEPEND="
+ sys-apps/acl
+ sys-apps/groff
+ app-text/ghostscript-gpl
+ >=sys-kernel/linux-headers-2.6.35"
+
+RDEPEND="
+ ${DEPEND}
+ sys-libs/libcap
+ sys-process/lsof
+ sys-libs/glibc"
+
+# Test fails with:
+# This is not a bug, but it does indicate where libexplain's ioctl support
+# could be improved.
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.45-configure.patch )
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ cp -v "${S}"/etc/configure.ac "${S}" || die
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+}