summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-25 18:18:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-25 22:54:36 +0200
commit91a42c15bfe50eb75791deab29deb83c4469ca05 (patch)
tree8f02e31c17a299bd0f7812f99a3b0b2067650f1e /dev-libs
parentmedia-sound/linuxsampler: Parallel build unsafe (diff)
downloadgentoo-91a42c15bfe50eb75791deab29deb83c4469ca05.tar.gz
gentoo-91a42c15bfe50eb75791deab29deb83c4469ca05.tar.bz2
gentoo-91a42c15bfe50eb75791deab29deb83c4469ca05.zip
dev-libs/quazip: 0.8 version bump
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/quazip/Manifest1
-rw-r--r--dev-libs/quazip/files/quazip-0.8-revert-FindQuaZip-location.patch23
-rw-r--r--dev-libs/quazip/quazip-0.8.ebuild50
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/quazip/Manifest b/dev-libs/quazip/Manifest
index 21e5d49acaa1..824bcc1e54da 100644
--- a/dev-libs/quazip/Manifest
+++ b/dev-libs/quazip/Manifest
@@ -1 +1,2 @@
DIST quazip-0.7.6.tar.gz 149029 BLAKE2B 7eb99f550dc06d8d2911b22214294accaa5126657598bfd60614267715ea968790f470cea2820e1a78a8581ab0d4b75c90589c0da1ae815067e083e389020762 SHA512 4325a69918216bb66c6a7c53589ef73473c3752151522a135dd9c92dbf722b29656aea7be0314c84399a214391eca79296ecda5811ab31845d8cf53c010110d1
+DIST quazip-0.8.tar.gz 150570 BLAKE2B 7478e80f250b5fd1dd3a09af2fec1c023de59a17020fb5d05eb0e6ed7276ff21341d8a80cec6944034fd3bc93e5e5c8bf38bb4a9735654388eca672527e7856e SHA512 f007760613d1f1899eb99cfb1ec49fee97d6a3a427b0cf6fe1421ebdfdefe7fc0317aebcca6bb79396fd8b32e8cda2ab65c019f1b7b85682bdea3e22900bbc8b
diff --git a/dev-libs/quazip/files/quazip-0.8-revert-FindQuaZip-location.patch b/dev-libs/quazip/files/quazip-0.8-revert-FindQuaZip-location.patch
new file mode 100644
index 000000000000..1d96af6791fb
--- /dev/null
+++ b/dev-libs/quazip/files/quazip-0.8-revert-FindQuaZip-location.patch
@@ -0,0 +1,23 @@
+From 6f5e2159dc7ee898ef08a9e3e3a8e0248d2d0caf Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 25 May 2019 18:13:58 +0200
+Subject: [PATCH] Revert "Install the FindQuaZip.cmake in the right prefix"
+
+This reverts commit d5eaa8be998da2430ffd43e0eefa617cf1550ca3.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a43fefe..539caa4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -60,4 +60,4 @@ set(QUAZIP_LIB_TARGET_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX} CACHE
+
+ add_subdirectory(quazip)
+
+-install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION share/cmake)
++install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_ROOT}/Modules)
+--
+2.21.0
+
diff --git a/dev-libs/quazip/quazip-0.8.ebuild b/dev-libs/quazip/quazip-0.8.ebuild
new file mode 100644
index 000000000000..34df694c62ae
--- /dev/null
+++ b/dev-libs/quazip/quazip-0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils flag-o-matic qmake-utils
+
+DESCRIPTION="Simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package"
+HOMEPAGE="https://stachenov.github.io/quazip/"
+SRC_URI="https://github.com/stachenov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-revert-FindQuaZip-location.patch" )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ if ! use static-libs ; then
+ sed -e "/^install/ s/quazip_static//" -i quazip/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local -x CXXFLAGS="${CXXFLAGS}"
+ append-cxxflags -std=c++11 -fPIC
+
+ local mycmakeargs=(
+ -DBUILD_WITH_QT4=OFF
+ -DLIB_SUFFIX=${libdir/lib/}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # compatibility with not yet fixed rdeps (Gentoo bug #598136)
+ dosym libquazip5.so /usr/$(get_libdir)/libquazip.so
+}