summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-03-30 06:18:01 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-03-30 06:18:23 -0400
commit982897606436ea62c63faec8a3556d5b6a1af8bf (patch)
treefa2b8a8a2c6c5722db3b22c4a81e54fadb9a0c89 /dev-libs
parentMask =sandbox-2.11 #578582 (diff)
downloadgentoo-982897606436ea62c63faec8a3556d5b6a1af8bf.tar.gz
gentoo-982897606436ea62c63faec8a3556d5b6a1af8bf.tar.bz2
gentoo-982897606436ea62c63faec8a3556d5b6a1af8bf.zip
dev-libs/xapian: version bump to 1.2.23
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.2.23.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index c04ed0007ab1..5abebe83799b 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -1,3 +1,4 @@
DIST xapian-core-1.2.19.tar.xz 3175384 SHA256 4a78260388ff1b042f0ab5d18afdd524a530ae609690d0339990ddc147a54785 SHA512 5cd29b8c278b4fa652f947cd6689945bbe239c95425344d0fedb445bf1534198333844d91e6e59cf870043066f4dc511cd0268071916002e96bd38b59aa91c1b WHIRLPOOL 5d65982d47145addc6585b72a99494bf6d14277df2c796925fbe6284ddd08b89fbc147c1a29575d573afebb2e2f6eb6dc73d58161260404be7e5ceefe1371ffb
DIST xapian-core-1.2.22.tar.xz 3204096 SHA256 269b87ca3faf79d444e8bb82ed58a96f1955008d7702f9966dec68608588527f SHA512 cb6bd565eb307f9bc8f801fc9cda0cc6ad5d7cb8bf0af2ab6e42d48ca4ea4169f08621db810ab87d15957d0f873bcb0336e16b12fdb6026375d9c0192781e0d6 WHIRLPOOL 580c16889a6c3e99a00f8bb791f878a08ff3522c3dffb18ace18d54575247332f0fff8866f46475513dde7544205fe08971cbd284ec3714ce0d6b9b445e8746e
+DIST xapian-core-1.2.23.tar.xz 3206452 SHA256 9783aeae4e1a6d06e5636b270db4b458a7d0804a31da158269f57fa5dc86347d SHA512 df3fa71150575faf982d6b90f2364962d61012dd45ed7ef4945a0623ed7056c32ea3cbc423f2016415a80779251ecb5080b6a34c5b66b823cf8d92fe6b5b3d30 WHIRLPOOL a5498117b060218455946948c119e52ed0639a2c2d5f1fd60e416ab06ad2cd483814039801d1fa29e097a994927d482a2bd10ab18bca28a413198ea1adb4187b
DIST xapian-core-1.3.4.tar.xz 2570240 SHA256 0a49da54a1eecb43de657f6341fde386f4c6e6bd1d2d64f77212adfc44bf67d4 SHA512 b616eb3532aaf7a00f58e6f21fa7309e434f9e598322793d2e81fe90da2a9d343518c9900bd30686594efeb24d370099f0df8f3a30afadb613ba19638f700617 WHIRLPOOL 167df88df4d12548e69e97e1163487f8a0eef93daedbac2c4a0bd4e4515dc2932c2bd044b2ec4905d251fdc69b460cb4ada67b511c2bfd8495eff8c5697b5271
diff --git a/dev-libs/xapian/xapian-1.2.23.ebuild b/dev-libs/xapian/xapian-1.2.23.ebuild
new file mode 100644
index 000000000000..8a79e365067c
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.23.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/1.2.22" # ABI version of libxapian.so, prefixed with 1.2.
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +brass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ einfo
+ if use cpu_flags_x86_sse2; then
+ einfo "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ einfo "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ einfo "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ einfo
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-flint --enable-backend-remote"
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}" || die
+ use doc || rm -rf "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+src_test() {
+ emake check VALGRIND=
+}