summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-08-03 11:35:59 -0700
committerMatt Turner <mattst88@gentoo.org>2020-08-03 11:37:41 -0700
commit9cb58563dd634f4b9feb12ac376af0ea7691d756 (patch)
tree625349f1534c9b699ab416a0f319a1f74759bd39 /dev-libs
parentdev-libs/libevdev: Add Python 3.9 compatibility (diff)
downloadgentoo-9cb58563dd634f4b9feb12ac376af0ea7691d756.tar.gz
gentoo-9cb58563dd634f4b9feb12ac376af0ea7691d756.tar.bz2
gentoo-9cb58563dd634f4b9feb12ac376af0ea7691d756.zip
dev-libs/libevdev: Version bump to 1.9.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libevdev/Manifest1
-rw-r--r--dev-libs/libevdev/libevdev-1.9.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/libevdev/Manifest b/dev-libs/libevdev/Manifest
index fff33e06310c..b2c037532aa8 100644
--- a/dev-libs/libevdev/Manifest
+++ b/dev-libs/libevdev/Manifest
@@ -1 +1,2 @@
DIST libevdev-1.9.0.tar.xz 443208 BLAKE2B 858567ec82f20d567f66d0c41bd1519ffd023a0374e346cff270a0bae0b5136a469a4fd56fcbd3d53b2a2ace6166821ec5e75c90e08eb347331e7974865ceda7 SHA512 6e7589b5776437ac23fbf65b3194fb1dd3a68a294696145060cdd97bcdeb9b04f355f2be028dc1a5efe98ef2cafca15e4f61115edf5d62591e3a8944dc95942a
+DIST libevdev-1.9.1.tar.xz 442740 BLAKE2B 8a0e6c555ffa09890556c33e346e03b878eb0dac8585164d7561b6e20e5795c39299508f761a1fa15737d0802e362ba5c9d17de89d96fb79f1bfa1afa28423ab SHA512 7d845ce2279d2e2ef12437f6218550265ea0c85e5b6c0d116aff09787b73626b338fe3084baff060085d393688b5ae3d33772689e0581684eff257af01c4c645
diff --git a/dev-libs/libevdev/libevdev-1.9.1.ebuild b/dev-libs/libevdev/libevdev-1.9.1.ebuild
new file mode 100644
index 000000000000..8f8dd07ac544
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.9.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit meson multilib-minimal python-any-r1
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ local HTML_DOCS=( doc/html/. )
+ einstalldocs
+ fi
+}