summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2018-09-17 11:40:25 +0200
committerGuilherme Amadio <amadio@gentoo.org>2018-09-17 11:40:25 +0200
commit9e004b8041e0ad0dac24797b8b7c0d26d0271cab (patch)
tree18d148dc87b423b08837d2367827b656c35a369b /dev-libs
parentx11-themes/qtcurve: Bump to version 1.9.0 (diff)
downloadgentoo-9e004b8041e0ad0dac24797b8b7c0d26d0271cab.tar.gz
gentoo-9e004b8041e0ad0dac24797b8b7c0d26d0271cab.tar.bz2
gentoo-9e004b8041e0ad0dac24797b8b7c0d26d0271cab.zip
Revert "dev-libs/xxhash: Compile xxhash.c just once, really"
This reverts commit 173c62837c28971e2c0c3bbc038ec16fe4930b38.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xxhash/files/xxhash-0.6.5-compile-xxhash.o-once.patch28
-rw-r--r--dev-libs/xxhash/files/xxhash-0.6.5-do-not-compile-xxhash.o-twice.patch11
-rw-r--r--dev-libs/xxhash/xxhash-0.6.5.ebuild2
3 files changed, 12 insertions, 29 deletions
diff --git a/dev-libs/xxhash/files/xxhash-0.6.5-compile-xxhash.o-once.patch b/dev-libs/xxhash/files/xxhash-0.6.5-compile-xxhash.o-once.patch
deleted file mode 100644
index 2eb7f8c22a8b..000000000000
--- a/dev-libs/xxhash/files/xxhash-0.6.5-compile-xxhash.o-once.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -82,7 +82,7 @@
- all: lib xxhsum xxhsum_inlinedXXH
-
- xxhsum32: CFLAGS += -m32
--xxhsum xxhsum32: xxhash.c xxhsum.c
-+xxhsum xxhsum32: xxhash.o xxhsum.c
- $(CC) $(FLAGS) $^ -o $@$(EXT)
-
- .PHONY: xxhsum_and_links
-@@ -105,12 +105,12 @@
- ifeq (,$(filter Windows%,$(OS)))
- $(LIBXXH): LDFLAGS += -fPIC
- endif
--$(LIBXXH): xxhash.c
-+$(LIBXXH): xxhash.o
- @echo compiling dynamic library $(LIBVER)
-- @$(CC) $(FLAGS) $^ $(LDFLAGS) $(SONAME_FLAGS) -o $@
-+ $(CC) $(FLAGS) $^ $(LDFLAGS) $(SONAME_FLAGS) -o $@
- @echo creating versioned links
-- @ln -sf $@ libxxhash.$(SHARED_EXT_MAJOR)
-- @ln -sf $@ libxxhash.$(SHARED_EXT)
-+ ln -sf $@ libxxhash.$(SHARED_EXT_MAJOR)
-+ ln -sf $@ libxxhash.$(SHARED_EXT)
-
- libxxhash : $(LIBXXH)
-
diff --git a/dev-libs/xxhash/files/xxhash-0.6.5-do-not-compile-xxhash.o-twice.patch b/dev-libs/xxhash/files/xxhash-0.6.5-do-not-compile-xxhash.o-twice.patch
new file mode 100644
index 000000000000..dcbc8c32dec9
--- /dev/null
+++ b/dev-libs/xxhash/files/xxhash-0.6.5-do-not-compile-xxhash.o-twice.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -82,7 +82,7 @@
+ all: lib xxhsum xxhsum_inlinedXXH
+
+ xxhsum32: CFLAGS += -m32
+-xxhsum xxhsum32: xxhash.c xxhsum.c
++xxhsum xxhsum32: xxhash.o xxhsum.c
+ $(CC) $(FLAGS) $^ -o $@$(EXT)
+
+ .PHONY: xxhsum_and_links
diff --git a/dev-libs/xxhash/xxhash-0.6.5.ebuild b/dev-libs/xxhash/xxhash-0.6.5.ebuild
index f01881f5cb10..18a037770e54 100644
--- a/dev-libs/xxhash/xxhash-0.6.5.ebuild
+++ b/dev-libs/xxhash/xxhash-0.6.5.ebuild
@@ -15,7 +15,7 @@ IUSE="static-libs"
S="${WORKDIR}/xxHash-${PV}"
PATCHES=(
- "${FILESDIR}"/${PN}-0.6.5-compile-xxhash.o-once.patch
+ "${FILESDIR}"/${PN}-0.6.5-do-not-compile-xxhash.o-twice.patch
)
src_compile() {