summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-18 18:37:50 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-18 19:06:57 -0700
commita04b0728b477fe78d8bf5cb691c24d02fd03fd9f (patch)
tree2f27a176f0892ebf3ef7a18e2d6de83405ebc3b7 /dev-libs
parentmedia-libs/mlt: Drop 6.18.0 (diff)
downloadgentoo-a04b0728b477fe78d8bf5cb691c24d02fd03fd9f.tar.gz
gentoo-a04b0728b477fe78d8bf5cb691c24d02fd03fd9f.tar.bz2
gentoo-a04b0728b477fe78d8bf5cb691c24d02fd03fd9f.zip
dev-libs/libreport: Version bump to 2.12.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libreport/Manifest1
-rw-r--r--dev-libs/libreport/libreport-2.12.0.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-libs/libreport/Manifest b/dev-libs/libreport/Manifest
index 1c1906dd4cae..1c28bd0fb52d 100644
--- a/dev-libs/libreport/Manifest
+++ b/dev-libs/libreport/Manifest
@@ -1 +1,2 @@
DIST libreport-2.10.0.tar.gz 2278084 BLAKE2B 95ac1fbf32e6e021e9553b35b10f9e46b7ea2e9cc6f21e53eb39a32a5261f7a6e49b2172381fdea30341fcc4311928691e68749a8bb5c41a4bf709151935687a SHA512 978ea442d82b75abf80b2075f540cb05c5577387a9221f2070c9695c4546d36169738d223f5e903d0b774b7e1566a6111c55a6bb51a0822ad1676095f067c45b
+DIST libreport-2.12.0.tar.gz 1842875 BLAKE2B 930666ec0c675a8ff457412a80511652dfa3bd3d771115506370432a7b74f3d1d9f6264dc3696c582b4a0939b2493137a18e1379eca268f25bc787a03a7d6c39 SHA512 d85c1beea330e4b21ce66b6f4acadaa132010738496a6701d161ee75b2254e629c496270145a6167e8eb81cf2204b0488aa0eb15c1e898f49aa3aec1331bff0c
diff --git a/dev-libs/libreport/libreport-2.12.0.ebuild b/dev-libs/libreport/libreport-2.12.0.ebuild
new file mode 100644
index 000000000000..7be927077753
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.12.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk +python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ >=dev-libs/glib-2.43.4:2
+ dev-libs/satyr:0=
+ dev-libs/json-c:=
+ dev-libs/libtar
+ dev-libs/libxml2:2
+ dev-libs/nettle:=
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ sys-apps/systemd
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ $(use_with gtk)
+ $(use_with python python3)
+ )
+ if use python; then
+ python_foreach_impl run_in_build_dir econf "${myargs[@]}"
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}