summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-12-10 14:21:49 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-12-10 14:26:47 +0100
commita08a9c303441cb0b9f30c2cd2ce76a590dc9140e (patch)
tree965d06f748d7bdaeeee0c01b1623d94835a1c1aa /dev-libs
parentdev-lua/luarocks: add 3.9.2 (diff)
downloadgentoo-a08a9c303441cb0b9f30c2cd2ce76a590dc9140e.tar.gz
gentoo-a08a9c303441cb0b9f30c2cd2ce76a590dc9140e.tar.bz2
gentoo-a08a9c303441cb0b9f30c2cd2ce76a590dc9140e.zip
dev-libs/libmodbus: add 3.1.10
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libmodbus/Manifest1
-rw-r--r--dev-libs/libmodbus/libmodbus-3.1.10.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libmodbus/Manifest b/dev-libs/libmodbus/Manifest
index 82542b5051da..8f452a90fb25 100644
--- a/dev-libs/libmodbus/Manifest
+++ b/dev-libs/libmodbus/Manifest
@@ -1,2 +1,3 @@
+DIST libmodbus-3.1.10.tar.gz 463325 BLAKE2B ea1c54e52f0927e9e97b2303b35925d6a40b30f1eed881eeed2d05a229c858ebdde6212431699e24a331744b30f447dfe6704c7ca0d4eb73d193ae5b5055c4b3 SHA512 d9a56d2cd3285823b287b6bf4f79741f2e626e09cfc1872405a306e8dcc0f64c15695e8aee45614071c615cd248b87293ef2351c830120a515d28303bad0ccee
DIST libmodbus-3.1.8.tar.gz 459999 BLAKE2B e5cb17dd260f3d0a25aedb2cecaa35f21c116458b0a46c7fe3ecc51d6ceb162fa387bb3ad18ff78c89f39645184ecc5bb164ef7cef2d091d2727750bdb0e429a SHA512 1158ac52cf92d3f8f8afaa23b67e841018f94c09521464a4c28ab724f7f2beb0eb567d574c2d81cfb1e3df9436cd2635b52a886656985b27df3a27693957d2df
DIST libmodbus-3.1.9.tar.gz 462649 BLAKE2B 2812b49a908af7906b596c0389050d688294ba415ee7e92211d8a8fb8868ec80388737fb2f7224e59b51861ee76b72cc7464a47b55ba5d086e89c9ff7d0f981b SHA512 6b26049939409ceba7dbafc079138553977dafac5284fdb39e1481c1d2ac29bef22123496819356f9e29d73705d3a9c71075823f0ad102293c4d9efd06fac00c
diff --git a/dev-libs/libmodbus/libmodbus-3.1.10.ebuild b/dev-libs/libmodbus/libmodbus-3.1.10.ebuild
new file mode 100644
index 000000000000..de8b52473bfe
--- /dev/null
+++ b/dev-libs/libmodbus/libmodbus-3.1.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Modbus library which supports RTU communication over a serial line or a TCP link"
+HOMEPAGE="https://libmodbus.org/"
+SRC_URI="https://github.com/stephane/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable test tests)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}