summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2023-04-17 09:45:44 +0000
committerSam James <sam@gentoo.org>2023-04-26 05:02:57 +0100
commita2770f1f6721086694290e1be99765de9a8e5cbd (patch)
treef0303f5609406c2ef26df9b6f5e753c3202ce4b7 /dev-libs
parentapp-editors/featherpad: drop 1.3.4 (diff)
downloadgentoo-a2770f1f6721086694290e1be99765de9a8e5cbd.tar.gz
gentoo-a2770f1f6721086694290e1be99765de9a8e5cbd.tar.bz2
gentoo-a2770f1f6721086694290e1be99765de9a8e5cbd.zip
dev-libs/modsecurity: add 3.0.9
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30628 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/modsecurity/Manifest1
-rw-r--r--dev-libs/modsecurity/modsecurity-3.0.9.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/modsecurity/Manifest b/dev-libs/modsecurity/Manifest
index 96a42dc0476a..2a0438072ef9 100644
--- a/dev-libs/modsecurity/Manifest
+++ b/dev-libs/modsecurity/Manifest
@@ -1 +1,2 @@
DIST modsecurity-v3.0.8.tar.gz 3336288 BLAKE2B de15124362f23c86a6dcee15dd847fcf703a378a57ebd4826a6304fed33b34f4791c7aa80abd42cbe5932063c1ca59f755345e3810dcbc296e2b6a758e0c580b SHA512 8113358548aea19a18de183922e979fd7ce9daad289c6894bda458176f17da63fb45160a2a86d97730c90191c881b232b1c9c6ab9209c3988b4390e49e086117
+DIST modsecurity-v3.0.9.tar.gz 3337195 BLAKE2B 5de70546463b9cf167e8e3fd13c55b3856dbe4f23f94a8f83a65890a4e5ea990597a0bb00f4dc24a52a3eb36fe6fa80a8d4a857f86bff3db5808b0d0bdd82b03 SHA512 49790031a82a6cece9cf53a03480490c0bdfd56302ea2e55319a27abdadf1aee060d4a9f847b224a21533d24f6a9fc29b4ad3898b258e6a81934a03c00e32020
diff --git a/dev-libs/modsecurity/modsecurity-3.0.9.ebuild b/dev-libs/modsecurity/modsecurity-3.0.9.ebuild
new file mode 100644
index 000000000000..d450dca9e74d
--- /dev/null
+++ b/dev-libs/modsecurity/modsecurity-3.0.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Application firewall and intrusion detection"
+HOMEPAGE="https://github.com/SpiderLabs/ModSecurity"
+SRC_URI="https://github.com/SpiderLabs/ModSecurity/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc fuzzyhash geoip geoip2 json lmdb lua pcre2"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RDEPEND="dev-libs/libpcre:=
+ dev-libs/libxml2
+ net-misc/curl
+ fuzzyhash? ( app-crypt/ssdeep )
+ geoip? ( dev-libs/geoip )
+ geoip2? ( dev-libs/libmaxminddb )
+ json? ( dev-libs/yajl )
+ lmdb? ( dev-db/lmdb )
+ lua? ( ${LUA_DEPS} )
+ pcre2? ( dev-libs/libpcre2:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=( AUTHORS CHANGES README.md modsecurity.conf-recommended unicode.mapping )
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with fuzzyhash ssdeep)
+ $(use_with geoip )
+ $(use_with geoip2 maxmind)
+ $(use_with json yajl)
+ $(use_with lmdb)
+ $(use_with lua)
+ $(use_with pcre2)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd doc && doxygen doxygen.cfg || die
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/html
+ find "${ED}" -name '*.la' -delete || die
+}