summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-29 11:10:27 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-29 11:16:19 -0700
commita63817f920a6fceb2dd3237ee311c47d76481665 (patch)
tree5e403c4c1e545fc96ca9eeb6e0185d0ec32a80c9 /dev-libs
parentdev-libs/libevdev: Drop old versions (diff)
downloadgentoo-a63817f920a6fceb2dd3237ee311c47d76481665.tar.gz
gentoo-a63817f920a6fceb2dd3237ee311c47d76481665.tar.bz2
gentoo-a63817f920a6fceb2dd3237ee311c47d76481665.zip
dev-libs/libinput: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.17.1.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index bc5c7d5ace57..a4b5fb3a49b8 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,2 @@
-DIST libinput-1.17.1.tar.xz 611492 BLAKE2B 274312240fccc49a45dedc3d41018bc952f25040217f388fd461aebabe796be106dd4f34cb2e40ce91fc75219c47fbd605c6facdc4d47893420e5df199a7edb7 SHA512 2e7baa198fed9c673d28453efb066f9371f2b575a844e41cde455c636bbe1cc68faae7129026944a502cd5d7bfcc72272066b9e3cda5c959f7b464483f9dd860
DIST libinput-1.17.2.tar.xz 611388 BLAKE2B a94ab1e3ef65f49a3043e5f84d68748c4800be1e2e0911b45be2a9cd6655311b2e6c2fcde64827f57e74318fc759d95e045125239305a2ae94175371c178c50a SHA512 b8953ad483648d5629d56c4dc226d4906693b15da5ba4027627a51ec35ea65b0603c09056b52ed2025df1f7a877669a5b7482c025e0b37003fc676563bd05263
DIST libinput-1.17.3.tar.xz 612892 BLAKE2B 1acae8a5bc0f87b547c83a0f72e0693ac95cf85377269efebc5ade8606620fcb3d7300fabb05dafd5492458da3d2300667ed6e43d9e6fcda2bd4f461bc0685a8 SHA512 3d1ab4362ede886996795d700a938d20e04cd922e8f9598fe9346f9f93e149119526fb324a096787b4b8a47bf3e5613130bcd874f10df86761031710d2acc792
diff --git a/dev-libs/libinput/libinput-1.17.1.ebuild b/dev-libs/libinput/libinput-1.17.1.ebuild
deleted file mode 100644
index 66c9079fcdc3..000000000000
--- a/dev-libs/libinput/libinput-1.17.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 2014-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit meson python-any-r1 udev
-
-DESCRIPTION="Library to handle input devices in Wayland"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/10"
-[[ "$(ver_cut 3)" -gt 900 ]] || \
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="doc input_devices_wacom test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- $(python_gen_any_dep '
- dev-python/commonmark[${PYTHON_USEDEP}]
- dev-python/recommonmark[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
- ')
- >=app-doc/doxygen-1.8.3
- >=media-gfx/graphviz-2.38.0
- )
-"
-# test? ( dev-util/valgrind )
-RDEPEND="
- input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
- >=dev-libs/libevdev-1.3
- >=sys-libs/mtdev-1.1
- virtual/libudev:=
- virtual/udev
-"
-DEPEND="${RDEPEND}
- test? ( >=dev-libs/check-0.9.10 )"
-
-python_check_deps() {
- has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
- has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
- has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
- sed "s@, '-Werror'@@" -i meson.build || die #744250
-}
-
-src_configure() {
- # gui can be built but will not be installed
- local emesonargs=(
- -Ddebug-gui=false
- $(meson_use doc documentation)
- $(meson_use input_devices_wacom libwacom)
- $(meson_use test tests)
- -Dudev-dir="${EPREFIX}$(get_udevdir)"
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- if use doc ; then
- docinto html
- dodoc -r "${BUILD_DIR}"/Documentation/.
- fi
-}
-
-pkg_postinst() {
- pkgname="dev-python/python-libevdev"
- if [[ -z "${REPLACING_VERSIONS}" ]] && ! has_version "${pkgname}" ; then
- einfo "${pkgname} must be installed to use the"
- einfo "libinput measure and libinput replay tools."
- fi
-
- udevadm hwdb --update --root="${ROOT}"
-}