summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2022-02-17 13:06:05 +0100
committerSam James <sam@gentoo.org>2022-03-21 23:45:22 +0000
commita810f63423e4b00b8e580614008c675ff86e5ee5 (patch)
tree55af6eed3806ac597b69e2c726eadaf7a58fa42d /dev-libs
parentmate-base/libmatekbd: add 1.26.0 (diff)
downloadgentoo-a810f63423e4b00b8e580614008c675ff86e5ee5.tar.gz
gentoo-a810f63423e4b00b8e580614008c675ff86e5ee5.tar.bz2
gentoo-a810f63423e4b00b8e580614008c675ff86e5ee5.zip
dev-libs/libmateweather: add 1.26.0
Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24231 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libmateweather/Manifest1
-rw-r--r--dev-libs/libmateweather/libmateweather-1.26.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/Manifest b/dev-libs/libmateweather/Manifest
index 21f4e9d492a0..c2ca88bd42ab 100644
--- a/dev-libs/libmateweather/Manifest
+++ b/dev-libs/libmateweather/Manifest
@@ -1 +1,2 @@
DIST libmateweather-1.24.1.tar.xz 2223880 BLAKE2B e9d86e66755760937e71b983adbd61a5d71a311b1550e7ed445e94d4f74efc4f5d4cf1af17558035c74a0c56b598cc7f464f4a011a873a2d00a26ad4c37c8209 SHA512 1e653a167b12593171bb3dcfae3a5e57b3f874b220c34ca4ad2e575da7df424ce8a71f88088f53ec53cf9614d40ecda48b088ef6bede680c0ce81dca35ee1156
+DIST libmateweather-1.26.0.tar.xz 2213064 BLAKE2B ae6670f60694627491890e3ff35550937f9b30431e3d6c48780e38c15a13d2a5812129e13c228f6a81004787e078ccc6c7410b75e17112f3afe993e5a7e061bd SHA512 e786071d8c9393abc6d8f0733bd213305ace50698066ba7913ac254d8944e6db94296de5ecf91c0d5a8babd38f0cc35cb3bcee046f1eb0339ec5429a66d062d1
diff --git a/dev-libs/libmateweather/libmateweather-1.26.0.ebuild b/dev-libs/libmateweather/libmateweather-1.26.0.ebuild
new file mode 100644
index 000000000000..db63bf49482c
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.26.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="LGPL-2.1+ GPL-2+"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.56:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.54:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}