summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-03-16 17:28:34 +0100
committerSam James <sam@gentoo.org>2021-05-04 22:02:15 +0000
commitab42e90c0df8cb286b35d6f27d0e7fbe6011e73d (patch)
tree34efb4c3433fa3f4f59b739ce1f95e8d5067445e /dev-libs
parentsci-libs/opencascade: bump to 7.5.1 (diff)
downloadgentoo-ab42e90c0df8cb286b35d6f27d0e7fbe6011e73d.tar.gz
gentoo-ab42e90c0df8cb286b35d6f27d0e7fbe6011e73d.tar.bz2
gentoo-ab42e90c0df8cb286b35d6f27d0e7fbe6011e73d.zip
dev-libs/imath: new package
Package starts with version 3.0.1, as it was historically outsourced from the ilmbase / openexr packages. Closes: https://bugs.gentoo.org/776607 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/imath/Manifest1
-rw-r--r--dev-libs/imath/imath-3.0.1.ebuild90
-rw-r--r--dev-libs/imath/metadata.xml25
3 files changed, 116 insertions, 0 deletions
diff --git a/dev-libs/imath/Manifest b/dev-libs/imath/Manifest
new file mode 100644
index 000000000000..6778d92c9bda
--- /dev/null
+++ b/dev-libs/imath/Manifest
@@ -0,0 +1 @@
+DIST imath-3.0.1.tar.gz 527715 BLAKE2B 45d8f6524fd2505bdb3318f571c44228c9baf6df869d194d4b90a9c045f1dbb8f905253aeaf6b6a9254e4b0c0c19d753b7e4ae068732f0367fc936d4a111520d SHA512 40cdae81d624636b3dd7eb456e6e205e5b7adf7aed17f6e9168374f8830f1b5755dcd32ac790f94e768513d06ab96d94a2bc57ec80a079e4ac94a3857e5e3988
diff --git a/dev-libs/imath/imath-3.0.1.ebuild b/dev-libs/imath/imath-3.0.1.ebuild
new file mode 100644
index 000000000000..bf6da0d3e7eb
--- /dev/null
+++ b/dev-libs/imath/imath-3.0.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit cmake python-single-r1
+
+MY_PN=Imath
+
+DESCRIPTION="Imath basic math package"
+HOMEPAGE="https://imath.readthedocs.io"
+SRC_URI="https://github.com/AcademySoftwareFoundation/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+# re-keywording needed for (according to ilmbase keywords):
+# ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x64-macos ~x86-solaris
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0/27"
+IUSE="doc large-stack python static-libs test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# libImath.so conflicts with ilmbase
+RDEPEND="
+ !media-libs/ilmbase
+ sys-libs/zlib
+ python? (
+ !dev-python/pyilmbase
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[python?,${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( $(python_gen_cond_dep 'dev-python/breathe[${PYTHON_MULTI_USEDEP}]') )
+ python? ( ${PYTHON_DEPS} )
+"
+
+DOCS=( CHANGES.md CONTRIBUTORS.md README.md SECURITY.md docs/PortingGuide2-3.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DIMATH_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DIMATH_INSTALL_PKG_CONFIG=ON
+ -DIMATH_USE_CLANG_TIDY=OFF
+ )
+
+ if use python; then
+ mycmakeargs+=(
+ -DPYTHON=ON
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc; then
+ pushd "${S}"/docs 2>/dev/null || die
+ doxygen || die
+ emake html
+ popd 2>/dev/null || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc; then
+ HTML_DOCS=( "${S}/docs/_build/html/." )
+ einstalldocs
+ fi
+}
diff --git a/dev-libs/imath/metadata.xml b/dev-libs/imath/metadata.xml
new file mode 100644
index 000000000000..e33071a52354
--- /dev/null
+++ b/dev-libs/imath/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>waebbl-gentoo@posteo.net</email>
+ <name>Bernd Waibel</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <description>Gentoo Proxy Maintainers</description>
+ </maintainer>
+ <longdescription>
+ Basic, light-weight C++ library for efficient representation of 2D
+ and 3D vectors and matrices and data type common to computer graphics
+ applications.
+ </longdescription>
+ <use>
+ <flag name="large-stack">
+ Enables code to take advantage of large stack support
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">AcademySoftwareFoundation/Imath</remote-id>
+ </upstream>
+</pkgmetadata>