summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-27 21:29:09 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-27 21:36:20 -0500
commitad2491b572d775028fa2df7063a5d04c96418e22 (patch)
tree8e0b2a6d05512bd200541e663bf7882fe87f3d9c /dev-libs
parentdev-util/wayland-scanner: Drop old versions (diff)
downloadgentoo-ad2491b572d775028fa2df7063a5d04c96418e22.tar.gz
gentoo-ad2491b572d775028fa2df7063a5d04c96418e22.tar.bz2
gentoo-ad2491b572d775028fa2df7063a5d04c96418e22.zip
dev-libs/wayland: Version bump to 1.19.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland/Manifest1
-rw-r--r--dev-libs/wayland/wayland-1.19.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/wayland/Manifest b/dev-libs/wayland/Manifest
index 6208e365ff88..98cf848aea69 100644
--- a/dev-libs/wayland/Manifest
+++ b/dev-libs/wayland/Manifest
@@ -1,3 +1,4 @@
DIST wayland-1.18.0.tar.xz 453968 BLAKE2B ee5b3f9dff07fda85b4d64bc753aff28c4a012184eb3a4bae8e3be0fb74324f12e9ea4e3dc049e06a11c7302e3c6b1e53e49109c814381641568d92b5572eed9 SHA512 e30199e30c2bbd361ee695b4f3f7a4e264f10ed8f46f2c90762b5739fc578ae757dc39aa0258d8fbf0ed418553470bccd4b2730ed9705481cfccdab5de96a8fc
DIST wayland-1.18.91.tar.xz 453500 BLAKE2B 6e234fa637bf4329fcf37c7372e3d02a50742812e2f61477ce302da4c2a1b9377874b0e4e2da899c726ede417081c4d459e40863169352825dd38a8fe0dcf267 SHA512 5ab770c87507e8248aa5197a253f27f3cca984bf1a69c52b438e9aaf512e6b0d841321f81c20643a49ef62eeb6c8b3a6391eadfee5c8822c3cf0d63bb0a8e0f8
DIST wayland-1.18.92.tar.xz 456320 BLAKE2B bd88156773b5ca817544e0aa496101dc144723dc7f4602011ce1bc4fedbbb20081d99fc882866c0f572139cf4bf4dcf1e7b181af48653b2c67622af07c7ab650 SHA512 837afe1accc632c445868a85792e708daa5d7dc5942888c2fa0981cfb0dd34a3d37667407f1875f04aa5710a07089f3b620a6b78dd19030b477d8b25941e6305
+DIST wayland-1.19.0.tar.xz 456380 BLAKE2B 0f70bb02e890898c4763001884527067adb686abe9a2b9325badf1730d411d269c437037afc298eec8075eb1e3845f5b81b8ed3d702908388a54e7063cbea91a SHA512 d8a86f5e23e4a88e7c84b82fdb51eb350419086afe462ecb2f4d5c3ba9290ede310cbbcffd60215219ddccf5bad4adec21a5ebfbef6577200f66ac7a1b64a5ef
diff --git a/dev-libs/wayland/wayland-1.19.0.ebuild b/dev-libs/wayland/wayland-1.19.0.ebuild
new file mode 100644
index 000000000000..c3d2b584f4ca
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.19.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+inherit meson multilib-minimal
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc"
+
+BDEPEND="
+ ~dev-util/wayland-scanner-${PV}[$MULTILIB_USEDEP]
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.6[dot]
+ app-text/xmlto
+ >=media-gfx/graphviz-2.26.0
+ )
+"
+DEPEND="
+ >=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:=
+ >=dev-libs/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+meson_multilib() {
+ if multilib_is_native_abi; then
+ echo true
+ else
+ echo false
+ fi
+}
+
+meson_multilib_native_use() {
+ if multilib_is_native_abi && use "$1"; then
+ echo true
+ else
+ echo false
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddocumentation=$(meson_multilib_native_use doc)
+ -Ddtd_validation=$(meson_multilib)
+ -Dlibraries=true
+ -Dscanner=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+src_test() {
+ # We set it on purpose to only a short subdir name, as socket paths are
+ # created in there, which are 108 byte limited. With this it hopefully
+ # barely fits to the limit with /var/tmp/portage/$CAT/$PF/temp/x
+ export XDG_RUNTIME_DIR="${T}"/x
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ multilib-minimal_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}