summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 10:12:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 11:12:16 +0200
commitaf673a4ea9a8dd2c2c12b7f837e31718548b681f (patch)
tree4baec35d3b9e8f5931061548eaf0d0e6352b3dee /dev-libs
parentdev-libs/kopeninghours: 23.04.0 version bump (diff)
downloadgentoo-af673a4ea9a8dd2c2c12b7f837e31718548b681f.tar.gz
gentoo-af673a4ea9a8dd2c2c12b7f837e31718548b681f.tar.bz2
gentoo-af673a4ea9a8dd2c2c12b7f837e31718548b681f.zip
dev-libs/kosmindoormap: 23.04.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kosmindoormap/Manifest1
-rw-r--r--dev-libs/kosmindoormap/kosmindoormap-23.04.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/kosmindoormap/Manifest b/dev-libs/kosmindoormap/Manifest
index fc10cb9557b6..62d3aa8e11af 100644
--- a/dev-libs/kosmindoormap/Manifest
+++ b/dev-libs/kosmindoormap/Manifest
@@ -1 +1,2 @@
DIST kosmindoormap-22.12.3.tar.xz 363564 BLAKE2B d21c51d96ef6d32c294bcd5c88992a4f562cddad9abb47f2694f7af76d7872f81084783ce5ac9bb01f558331c6968c02b1247a854ef5e29975bf04b7cc74199a SHA512 ac0632180ac527b2b2e8856af2ee060b86b80b531c08b47439c3293d18f356c69a60ce4bf8fdd64511937f934dc49c5211c8a55956976c82943032e24baf8069
+DIST kosmindoormap-23.04.0.tar.xz 374760 BLAKE2B ce43556b0acdd43be6017cb3f2898bee2f3b3265fc1961825ebd2c6ab16980cc516a263d5a544587f4782200c805081858e89de4465fcd849a4c55f5e92849ff SHA512 0033dc241e8ca6fdce1909aeb18771a03e5ac15f81ad736ce22791513163c22e54e4e9712c9c7213c4704e5723dbc9d7c9a1a9b2a7594eb3d4089b9ded9da0f8
diff --git a/dev-libs/kosmindoormap/kosmindoormap-23.04.0.ebuild b/dev-libs/kosmindoormap/kosmindoormap-23.04.0.ebuild
new file mode 100644
index 000000000000..f4c00c3cfbc2
--- /dev/null
+++ b/dev-libs/kosmindoormap/kosmindoormap-23.04.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.104.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
+HOMEPAGE="https://invent.kde.org/libraries/kosmindoormap"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="+openinghours"
+
+COMMON_DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ dev-libs/protobuf:=
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ openinghours? ( >=dev-libs/kopeninghours-${PVCUT}:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ $(cmake_use_find_package openinghours KOpeningHours)
+ )
+ ecm_src_configure
+}