summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-23 22:13:53 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-24 19:20:15 -0700
commitb0aa96688d7af4a926fd06df082a6de9ae57bec8 (patch)
treee1982835d714ad5d52bd9cfe45313d768c5dd791 /dev-libs
parentnet-mail/b4: import 0.3.4 (diff)
downloadgentoo-b0aa96688d7af4a926fd06df082a6de9ae57bec8.tar.gz
gentoo-b0aa96688d7af4a926fd06df082a6de9ae57bec8.tar.bz2
gentoo-b0aa96688d7af4a926fd06df082a6de9ae57bec8.zip
dev-libs/gobject-introspection-common: Version bump to 1.64.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gobject-introspection-common/Manifest1
-rw-r--r--dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection-common/Manifest b/dev-libs/gobject-introspection-common/Manifest
index 83ad50553dd5..4606cfc104a1 100644
--- a/dev-libs/gobject-introspection-common/Manifest
+++ b/dev-libs/gobject-introspection-common/Manifest
@@ -1,2 +1,3 @@
DIST gobject-introspection-1.60.2.tar.xz 1285000 BLAKE2B 43d96bbac8dd6600726876277f945e7eb01dba2063907c21960cbf5f49d766ac156ed116641b69dfe28f3025c4b482ffd39e8e107aba9ee48010a500111a58e4 SHA512 8e8c1c3a025cb6c18933302ada8cce7c4826f22eef791c80a97abb28379239f8d99312e1237bcea1060f4d5cf65441909b9da434561982209bb4976b1f22529e
DIST gobject-introspection-1.62.0.tar.xz 980732 BLAKE2B 96ecc98bea97b7cb24e2c0a0adb8158cfc8915ee8e3b980adf08ec3256d4d0f87bc92d33cce30f5b23c85c4b144d8da755e5313735091b27ff53fea45a80014e SHA512 b460a95fd7a323e9b0c9a45e680ebe98bbae7632abfa53b3e0b0ec050775cab17dde693314d6d4f8e93614c32b5587f8ce0b4a4c9ee9ba46c029ce029014e638
+DIST gobject-introspection-1.64.0.tar.xz 1000240 BLAKE2B 09e6dec65a53a107bee387cef9cb271345ae564f3520bd9a6485cf1796deaa47243c05f45a72f3243e811a2c1962a2ae123a6b344819187cbf36eae0ed58fbaa SHA512 d1960424d82dea1f1d36a7c3f9922029e751e77da8dc6904c24750babe7c3f4c11a6795eb218aab342ccbb6326d0ac3eac2c2c903e90b146f4e28c0f413da1ae
diff --git a/dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild
new file mode 100644
index 000000000000..70eb0234f5dc
--- /dev/null
+++ b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gobject-introspection"
+
+inherit gnome.org
+
+DESCRIPTION="Build infrastructure for GObject Introspection"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<${CATEGORY}/${GNOME_ORG_MODULE}-${PV}"
+# Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
+# https://forums.gentoo.org/viewtopic-p-7421930.html
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins m4/introspection.m4
+
+ insinto /usr/share/gobject-introspection-1.0
+ doins Makefile.introspection
+}