summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-05-16 21:34:42 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-05-16 21:34:42 +0300
commitb625fcf97c9ce2dba9712b1beda3f2ca8bc6410a (patch)
tree06d152a36bc26d8cd5cae73f74bb77cf04a6005b /dev-libs
parentsys-auth/pam_p11: version bump (diff)
downloadgentoo-b625fcf97c9ce2dba9712b1beda3f2ca8bc6410a.tar.gz
gentoo-b625fcf97c9ce2dba9712b1beda3f2ca8bc6410a.tar.bz2
gentoo-b625fcf97c9ce2dba9712b1beda3f2ca8bc6410a.zip
dev-libs/opensc: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/opensc/Manifest1
-rw-r--r--dev-libs/opensc/files/opensc-0.18.0-build.patch32
-rw-r--r--dev-libs/opensc/opensc-0.18.0.ebuild60
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/opensc/Manifest b/dev-libs/opensc/Manifest
index 9c821f16b703..400ac494bc1e 100644
--- a/dev-libs/opensc/Manifest
+++ b/dev-libs/opensc/Manifest
@@ -1,2 +1,3 @@
DIST opensc-0.16.0.tar.gz 1760418 BLAKE2B 7f5799445e285010392f315fa57919c7f0b038170a19e83dbda664d5d73898f075cccad4304275402c900b9fc50564ed5515a10d31156a6c76a68f170ca3e439 SHA512 15f7d62388dde6dad226acab3cd54f8e2f2f53684dc0cb976c6fc6fbdb4487be931ca69bf965ab07c51efd16be64d5411f10bacea11a07fc823c92dd7bb25139
DIST opensc-0.17.0.tar.gz 1950547 BLAKE2B 861dbb60e211d503332228c9d75d667f70cb9e15883c571821bb2f7703ca62dd4ce56c5ea7965e2d5e8c6a81b5063fc689013670294426baf1bfaec88282e20e SHA512 8991c1724d187d3c34a2ed591b21f0085f767c0d866edc2decfda85a2b3dedf717838f4937d1dda3e1bbc17f02e6eca6740299660128bc448a29e8bfc2962922
+DIST opensc-0.18.0.tar.gz 2037073 BLAKE2B f2b339d1f9c616f6f706acb3c55289deb5b1749a8b5561142c69db4ed1c7dee554ce1f8d820e6e69bb9e462ca460379badf3017ed35fa6cd395702c995326c3e SHA512 dc90cff3e0e639c14bfb11d1d0455964d24d08aa27728592ab0d8b487a1ffee1ca71cb9bbf5d0f101b2ebd85cf9478988f686d45effa72315e6ffc843d398768
diff --git a/dev-libs/opensc/files/opensc-0.18.0-build.patch b/dev-libs/opensc/files/opensc-0.18.0-build.patch
new file mode 100644
index 000000000000..2bea2e53d595
--- /dev/null
+++ b/dev-libs/opensc/files/opensc-0.18.0-build.patch
@@ -0,0 +1,32 @@
+From 1f1de5ae9a43e845431dc43af96ec61e910ad789 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Wed, 16 May 2018 21:30:15 +0300
+Subject: [PATCH] build: fix --disable-sm
+
+---
+ src/libopensc/card-sc-hsm.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/libopensc/card-sc-hsm.c b/src/libopensc/card-sc-hsm.c
+index e2af52b9..a609f612 100644
+--- a/src/libopensc/card-sc-hsm.c
++++ b/src/libopensc/card-sc-hsm.c
+@@ -451,6 +451,7 @@ static int sc_hsm_soc_biomatch(sc_card_t *card, struct sc_pin_cmd_data *data,
+
+
+
++#ifdef ENABLE_SM
+ #ifdef ENABLE_OPENPACE
+ #include "sm/sm-eac.h"
+ #include <eac/cv_cert.h>
+@@ -573,6 +574,7 @@ static int sc_hsm_perform_chip_authentication(sc_card_t *card)
+ return SC_ERROR_NOT_SUPPORTED;
+ }
+ #endif
++#endif
+
+
+
+--
+2.16.1
+
diff --git a/dev-libs/opensc/opensc-0.18.0.ebuild b/dev-libs/opensc/opensc-0.18.0.ebuild
new file mode 100644
index 000000000000..9693228d0a48
--- /dev/null
+++ b/dev-libs/opensc/opensc-0.18.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+DESCRIPTION="Libraries and applications to access smartcards"
+HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
+SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc +pcsc-lite secure-messaging openct ctapi readline libressl ssl zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ readline? ( sys-libs/readline:0= )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ openct? ( >=dev-libs/openct-0.5.0 )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+REQUIRED_USE="
+ pcsc-lite? ( !openct !ctapi )
+ openct? ( !pcsc-lite !ctapi )
+ ctapi? ( !pcsc-lite !openct )
+ || ( pcsc-lite openct ctapi )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --htmldir='$(docdir)/html' \
+ --disable-static \
+ --disable-openpace \
+ $(use_enable doc) \
+ $(use_enable openct) \
+ $(use_enable readline) \
+ $(use_enable zlib) \
+ $(use_enable secure-messaging sm) \
+ $(use_enable ssl openssl) \
+ $(use_enable pcsc-lite pcsc) \
+ $(use_enable openct) \
+ $(use_enable ctapi)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}