summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-15 03:56:50 +0100
committerSam James <sam@gentoo.org>2021-04-16 12:15:45 +0100
commitbdff40d4ef0bba22c92407db6b230ecb0c034f3c (patch)
treec02833070a7aa74ad4e65cbe76716f482461c955 /dev-libs
parentdev-libs/libcoyotl: eutils->epatch (diff)
downloadgentoo-bdff40d4ef0bba22c92407db6b230ecb0c034f3c.tar.gz
gentoo-bdff40d4ef0bba22c92407db6b230ecb0c034f3c.tar.bz2
gentoo-bdff40d4ef0bba22c92407db6b230ecb0c034f3c.zip
dev-libs/libdbh: eutils--, style changes
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libdbh/libdbh-5.0.19.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/dev-libs/libdbh/libdbh-5.0.19.ebuild b/dev-libs/libdbh/libdbh-5.0.19.ebuild
index 81bdaa952a54..f60a44b4b2fc 100644
--- a/dev-libs/libdbh/libdbh-5.0.19.ebuild
+++ b/dev-libs/libdbh/libdbh-5.0.19.ebuild
@@ -1,30 +1,27 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit autotools eutils
+
+inherit autotools
MY_P=${PN}2-${PV}
DESCRIPTION="a small library to create and manage 64-bit disk based hash tables"
HOMEPAGE="https://www.gnu.org/software/libdbh/"
SRC_URI="mirror://sourceforge/dbh/dbh/${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
+DEPEND="
dev-util/gtk-doc-am
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
-S="${WORKDIR}"/${MY_P}
-
-pkg_setup() {
- DOCS=( AUTHORS ChangeLog NEWS README TODO )
-}
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
src_prepare() {
sed -i -e "s:-O2:${CFLAGS}:" m4/rfm-conditionals.m4 || die
@@ -37,5 +34,6 @@ src_configure() {
src_install() {
default
+ einstalldocs
find "${ED}" -name '*.la' -delete || die
}