summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Andrejak <thomas.andrejak@gmail.com>2020-09-29 01:16:29 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-12 15:39:46 +0300
commitbf6f566b80397fd41cd46cb29efe966251cf21dc (patch)
treed0559e546c5f6907d81c45e33a5aac99feb1b2f6 /dev-libs
parentdev-libs/libprelude: Bump version 5.2.0 (diff)
downloadgentoo-bf6f566b80397fd41cd46cb29efe966251cf21dc.tar.gz
gentoo-bf6f566b80397fd41cd46cb29efe966251cf21dc.tar.bz2
gentoo-bf6f566b80397fd41cd46cb29efe966251cf21dc.zip
dev-libs/libpreludedb: Bump version 5.2.0
Signed-off-by: Thomas Andrejak <thomas.andrejak@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libpreludedb/Manifest1
-rw-r--r--dev-libs/libpreludedb/libpreludedb-5.2.0.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-libs/libpreludedb/Manifest b/dev-libs/libpreludedb/Manifest
index fb2212e28bd1..3a04f85d8ad9 100644
--- a/dev-libs/libpreludedb/Manifest
+++ b/dev-libs/libpreludedb/Manifest
@@ -1,3 +1,4 @@
DIST libpreludedb-4.0.0.tar.gz 1325812 BLAKE2B 7a506f7cd7b51898e26201f2cc640b1f34227f9cf7c5c6e2385480f1fc0ad854b6d747293ab502b641cc65f1ee9ae4a8f225e6a1d4489bcaa59901c6342f1279 SHA512 13f5dbcfa6af965f2075d60c645ebb19cbd6b18807b26f4f13a7a05f1cf552996f9846e856728a4e1dc621efda693016e82623d4a3cbf74849b3e7114f19faca
DIST libpreludedb-4.1.0.tar.gz 1333638 BLAKE2B 380a6d4ef8836555510f9f9882b6100417f2567520c421355fb7eec8d2cd7e2f3942c4cb90ea21fa1557327026edd5c1e35e338a79e06a21cfb2bd6813a289c2 SHA512 de1fa5106d7f34edb5a23e726c968de84bb8b10257587b6ee36276ed75ddc54f4f9539aecb7836e114eb3bfa90104dd3b5e097be0c3d12347dcbded94f293dc4
DIST libpreludedb-5.1.0.tar.gz 1374511 BLAKE2B 569324a5ae484b1d13ac729f25a2f7f8924a8dced923859cdc393289acf0c0cf098ae6e0f9f572a707c85aa9af4a27bbaa0927e20d610b423e2aae86718d232b SHA512 9e45e0f7a945eef254f8e59c0c7212c6afca897584ea8f2c88e16478fde448abdeeb991828cc2482373d2c735e1229f1a11fe9780e40da1a8aed867fe158f481
+DIST libpreludedb-5.2.0.tar.gz 1372810 BLAKE2B 5a6bed23eba77591b8e97bb3c6f2b321970c94f88fb86094146a1a3fa64cc0f0c97ca1d1488b2202ab7042207ca2ca4f74029415ef1ca6ea13c84d158a23473f SHA512 357e3ce69927ed405bc757774466631d34cad9b53031be6ce456238dd8aef3781471ecbb36ab4a3131468f4686a635095aaf837d23a0efc9db758322298e7744
diff --git a/dev-libs/libpreludedb/libpreludedb-5.2.0.ebuild b/dev-libs/libpreludedb/libpreludedb-5.2.0.ebuild
new file mode 100644
index 000000000000..c60925e967f2
--- /dev/null
+++ b/dev-libs/libpreludedb/libpreludedb-5.2.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_OPTIONAL=1
+
+inherit autotools distutils-r1
+
+DESCRIPTION="Framework to easy access to the Prelude database"
+HOMEPAGE="https://www.prelude-siem.org"
+SRC_URI="https://www.prelude-siem.org/pkg/src/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql postgres python sqlite"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/libprelude-5.2.0
+ <dev-libs/libprelude-6
+ net-libs/gnutls:=
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:* )
+ python? ( ${PYTHON_DEPS} )
+ sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND=">=dev-lang/swig-4.0.0
+ dev-util/gtk-doc-am
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+ python? ( ${PYTHON_DEPS} )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.0-fix-python-bindings.patch"
+ "${FILESDIR}/${PN}-5.1.0-fix_gtkdoc_1.32.patch"
+ "${FILESDIR}/${PN}-5.1.0-update_m4_postgresql.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use python; then
+ cd bindings/python || die
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ --enable-easy-bindings
+ --without-swig
+ --without-python2
+ --localstatedir="${EPREFIX}/var"
+ $(use_with mysql)
+ $(use_with postgres postgresql)
+ $(use_with sqlite sqlite3)
+ )
+
+ if use python; then
+ python_setup
+ myconf+=( --with-python3="${EPYTHON}" )
+ else
+ myconf+=( --without-python3 )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ if use python; then
+ cd bindings/python || die
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ if use python; then
+ cd bindings/python || die
+ distutils-r1_src_install
+ fi
+}