summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-24 00:17:26 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-24 00:17:26 +0900
commitc451044b82626438dbb13028eb3a76c6928c771e (patch)
tree283e55ed0f102e980daf1a734a5b3ddd1926b9c0 /dev-libs
parentdev-libs/eekboard: initial import (diff)
downloadgentoo-c451044b82626438dbb13028eb3a76c6928c771e.tar.gz
gentoo-c451044b82626438dbb13028eb3a76c6928c771e.tar.bz2
gentoo-c451044b82626438dbb13028eb3a76c6928c771e.zip
dev-libs/input-pad: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/input-pad/Manifest1
-rw-r--r--dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild52
-rw-r--r--dev-libs/input-pad/metadata.xml15
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/input-pad/Manifest b/dev-libs/input-pad/Manifest
new file mode 100644
index 000000000000..de5718937d5b
--- /dev/null
+++ b/dev-libs/input-pad/Manifest
@@ -0,0 +1 @@
+DIST input-pad-1.0.99.20140916.tar.gz 621070 SHA256 e0769e5e6fe4d741d25189ebe98dbf0f9d7edc1a516025783c0574799684159c SHA512 a7dd7996f69dbb6cc200be3c181e82ef8d701f85f1b27a886a8910afb3e673c1d71878e70b79141570a28a31dd47565868a990a358058ae8b99c29c76a316261 WHIRLPOOL d6121617a31f864e622cc02007faa033a1e0357760543f3b30dee064fb9b16867a0d366a062df313677ede74831f39a386eada85dcd1a1f32f03599191f033da
diff --git a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
new file mode 100644
index 000000000000..f884a5d7fb2b
--- /dev/null
+++ b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune xdg-utils
+
+MY_P="${P/_pre/.}"
+MY_PV="${PV/_pre/.}"
+
+DESCRIPTION="On-screen input pad to send characters with mouse"
+HOMEPAGE="https://github.com/fujiwarat/input-pad/wiki"
+SRC_URI="https://github.com/fujiwarat/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eekboard +introspection static-libs +xtest"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/libxklavier
+ virtual/libintl
+ eekboard? ( dev-libs/eekboard )
+ introspection? ( dev-libs/gobject-introspection )
+ xtest? ( x11-libs/libXtst )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable eekboard eek) \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable xtest)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/input-pad/metadata.xml b/dev-libs/input-pad/metadata.xml
new file mode 100644
index 000000000000..fc144ccafd3d
--- /dev/null
+++ b/dev-libs/input-pad/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <use>
+ <flag name="eekboard">Enable support for <pkg>dev-libs/eekboard</pkg></flag>
+ <flag name="xtest">Enable support for <pkg>x11-libs/libXtst</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">fujiwarat/input-pad</remote-id>
+ </upstream>
+</pkgmetadata>