summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2016-05-30 12:24:36 +0200
committerMichael Haubenwallner <haubi@gentoo.org>2016-05-30 12:25:22 +0200
commitc787140b95ec648524a5f50ac561243e2e4f91e9 (patch)
treebec6e3e131c62589a832cffe762cd30347cfc948 /dev-libs
parentnet-misc/wget: add gnulib cygwin patch (#584312) (diff)
downloadgentoo-c787140b95ec648524a5f50ac561243e2e4f91e9.tar.gz
gentoo-c787140b95ec648524a5f50ac561243e2e4f91e9.tar.bz2
gentoo-c787140b95ec648524a5f50ac561243e2e4f91e9.zip
dev-libs/libpipeline: add gnulib cygwin patch (#584314)
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libpipeline/files/libpipeline-1.4.1-gnulib-cygwin-sys_select.patch22
-rw-r--r--dev-libs/libpipeline/libpipeline-1.4.1.ebuild4
2 files changed, 25 insertions, 1 deletions
diff --git a/dev-libs/libpipeline/files/libpipeline-1.4.1-gnulib-cygwin-sys_select.patch b/dev-libs/libpipeline/files/libpipeline-1.4.1-gnulib-cygwin-sys_select.patch
new file mode 100644
index 000000000000..07551361793f
--- /dev/null
+++ b/dev-libs/libpipeline/files/libpipeline-1.4.1-gnulib-cygwin-sys_select.patch
@@ -0,0 +1,22 @@
+https://lists.gnu.org/archive/html/bug-gnulib/2016-03/msg00065.html
+
+--- gnulib/lib/sys_select.in.h.orig 2014-08-03 15:31:22.000000000 +0200
++++ gnulib/lib/sys_select.in.h 2016-05-19 12:57:51.243064700 +0200
+@@ -81,7 +81,7 @@
+ Also, Mac OS X, AIX, HP-UX, IRIX, Solaris, Interix declare select()
+ in <sys/time.h>.
+ But avoid namespace pollution on glibc systems. */
+-# ifndef __GLIBC__
++# if !(defined __GLIBC__ || defined __NEWLIB__)
+ # include <sys/time.h>
+ # endif
+
+@@ -102,7 +102,7 @@
+ But avoid namespace pollution on glibc systems.
+ Do this after the include_next (for the sake of OpenBSD 5.0) but before
+ the split double-inclusion guard (for the sake of Solaris). */
+-#if !(defined __GLIBC__ && !defined __UCLIBC__)
++#if !((defined __GLIBC__ || defined __NEWLIB__) && !defined __UCLIBC__)
+ # include <signal.h>
+ #endif
+
diff --git a/dev-libs/libpipeline/libpipeline-1.4.1.ebuild b/dev-libs/libpipeline/libpipeline-1.4.1.ebuild
index e14dfd798c1f..ab244564d300 100644
--- a/dev-libs/libpipeline/libpipeline-1.4.1.ebuild
+++ b/dev-libs/libpipeline/libpipeline-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,3 +17,5 @@ IUSE="static-libs test"
DEPEND="virtual/pkgconfig
test? ( dev-libs/check )"
+
+PATCHES=( "${FILESDIR}"/${P}-gnulib-cygwin-sys_select.patch )