summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-01-02 22:54:42 -0500
committerMatt Turner <mattst88@gentoo.org>2023-01-03 09:07:47 -0500
commitc963b4d286e457c8245b2681a41897494a7bdac7 (patch)
tree02c3e78f5caf4228cc5781258941678be84e29b2 /dev-libs
parentdev-libs/appstream-glib: Drop old versions (diff)
downloadgentoo-c963b4d286e457c8245b2681a41897494a7bdac7.tar.gz
gentoo-c963b4d286e457c8245b2681a41897494a7bdac7.tar.bz2
gentoo-c963b4d286e457c8245b2681a41897494a7bdac7.zip
dev-libs/gjs: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.72.2-r1.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index 5e41d96d46d7..5ffaae812bbb 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,2 +1 @@
-DIST gjs-1.72.2.tar.xz 620380 BLAKE2B 5ea15bdf25c36fa0236f03adea5b2261db3923190005754119eacd070830e7baedfa842ab273219055f67f7af535d31d5844c76eddfb03a8ec1cab57297ec258 SHA512 0dd10f40e8811bbb79c541cf3dc4e3759c0e025485e4b8ad2870dc30ac8030573300bc178c78bf2d396b86733e36b33210bfbdeead6a314e592d5b3c250a16a2
DIST gjs-1.74.1.tar.xz 638536 BLAKE2B 375abcaa20a538cfa271f7dcf6f3715e4324ff5a4a9482ce0dd7f78213598a715ebc034f701fe458876f841f72802db4ae2aabf0abc04dc4ac5bb39c917741fd SHA512 346667accb589df0e6a045e30782017eab928115f263d36d521b61b0af38fd268bc518b8ab5ec78e5d25e0194b744a2ee59e65668da679e138b2122858ce0614
diff --git a/dev-libs/gjs/gjs-1.72.2-r1.ebuild b/dev-libs/gjs/gjs-1.72.2-r1.ebuild
deleted file mode 100644
index 62bb94cec789..000000000000
--- a/dev-libs/gjs/gjs-1.72.2-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic gnome.org meson virtualx
-
-DESCRIPTION="Javascript bindings for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
-
-LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
-SLOT="0"
-IUSE="+cairo examples readline sysprof test"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.66.0:2
- dev-libs/libffi:=
- >=dev-libs/gobject-introspection-1.66.1:=
- >=dev-lang/spidermonkey-91.3.0:91
- cairo? ( x11-libs/cairo[X,glib,svg(+)] )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="${RDEPEND}
- sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
- test? (
- sys-apps/dbus
- >=x11-libs/gtk+-3.20:3[introspection]
- )
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_configure() {
- append-cppflags -DG_DISABLE_CAST_CHECKS
-
- # On musl, it's required that either gjs, pixman or gnome-shell to be built
- # with a larger stack otherwise librsvg fails to render a particular SVG, as
- # a result we fail to get gdm or gnome-shell running (greeted with a fail
- # whale screen). The bug has been reported to librsvg. This is ideally just
- # a temporary workaround until we understand what exactly needs a larger
- # stack size, as it's not sufficient to do just librsvg.
- #
- # Please refer to:
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
- #
- # TODO: Find an actual fix instead of increasing the stack
- use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
-
- # FIXME: add systemtap/dtrace support, like in glib:2
- local emesonargs=(
- $(meson_feature cairo)
- $(meson_feature readline)
- $(meson_feature sysprof profiler)
- -Dinstalled_tests=false
- $(meson_use !test skip_dbus_tests)
- $(meson_use !test skip_gtk_tests)
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}