summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-11-19 09:30:04 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-11-19 09:30:24 +0200
commitcc54e105e8eed1c2de1bd1a48ad2082805fb2be6 (patch)
tree96a2a3b4f44d2ec30073d4237abfd03562732d3b /dev-libs
parentdev-libs/raft: add 0.16.0 (diff)
downloadgentoo-cc54e105e8eed1c2de1bd1a48ad2082805fb2be6.tar.gz
gentoo-cc54e105e8eed1c2de1bd1a48ad2082805fb2be6.tar.bz2
gentoo-cc54e105e8eed1c2de1bd1a48ad2082805fb2be6.zip
dev-libs/dqlite: add 1.12.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/dqlite/Manifest1
-rw-r--r--dev-libs/dqlite/dqlite-1.12.0.ebuild45
-rw-r--r--dev-libs/dqlite/files/dqlite-1.12.0-disable-werror.patch20
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/dqlite/Manifest b/dev-libs/dqlite/Manifest
index d9c19d867d19..bb84b8985d3f 100644
--- a/dev-libs/dqlite/Manifest
+++ b/dev-libs/dqlite/Manifest
@@ -1 +1,2 @@
DIST dqlite-1.11.1.tar.gz 172024 BLAKE2B 48fb3c4eebc1f1a2d341254f9f0ad01f871b65fac727b132b80ac59eceb7d1ab95ac6118549ab39c8b032053a8791d6abef5e0d4856da7e45f00939b083463e5 SHA512 64d9a6548a4d75e3045adf5e31d54c508a02b255573225d32119225260c3d5219c4ac29c857ba054cd3fa3df54ee81cf88bbc2f9769839902f63f0f8c02cc6c7
+DIST dqlite-1.12.0.tar.gz 181709 BLAKE2B efb35aa9d0c348cd55eb190e27ad155b7d748ccbcb80822f33ce4589d56bc0090f5c0703d769e7090bb8da1b8908cbd73d1076568108661d5b85e55103795a9f SHA512 2a3dc17fcaa0ec2fc5481d3ff57a7bee42c8930f0e6ac7030d51e1a61ae3ce4d7b24f47921b29602a65353c1a51931a82d9af302ee580b19bdce561e6547e940
diff --git a/dev-libs/dqlite/dqlite-1.12.0.ebuild b/dev-libs/dqlite/dqlite-1.12.0.ebuild
new file mode 100644
index 000000000000..4ca71ad7217d
--- /dev/null
+++ b/dev-libs/dqlite/dqlite-1.12.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Embeddable, replicated and fault tolerant SQL engine"
+HOMEPAGE="https://dqlite.io/ https://github.com/canonical/dqlite"
+SRC_URI="https://github.com/canonical/dqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/libuv:=
+ >=dev-libs/raft-0.14.0"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/raft-0.13.0[lz4,test] )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/dqlite-1.12.0-disable-werror.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-debug
+ --disable-sanitize
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/dqlite/files/dqlite-1.12.0-disable-werror.patch b/dev-libs/dqlite/files/dqlite-1.12.0-disable-werror.patch
new file mode 100644
index 000000000000..9c92324688d6
--- /dev/null
+++ b/dev-libs/dqlite/files/dqlite-1.12.0-disable-werror.patch
@@ -0,0 +1,20 @@
+diff -Naur a/configure.ac b/configure.ac
+--- a/configure.ac 2022-11-18 16:44:34.000000000 +0200
++++ b/configure.ac 2022-11-19 09:21:24.157589426 +0200
+@@ -3,7 +3,7 @@
+ AC_CONFIG_MACRO_DIR([m4])
+ AC_CONFIG_AUX_DIR([ac])
+
+-AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror -Wno-portability foreign])
++AM_INIT_AUTOMAKE([subdir-objects -Wall -Wno-portability foreign])
+ AM_SILENT_RULES([yes])
+
+ AC_PROG_CC_STDC
+@@ -82,7 +82,6 @@
+ -Wdate-time \
+ -Wnested-externs \
+ -Wconversion \
+- -Werror \
+ ])
+ # To enable:
+ #