summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-05-05 03:51:30 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-10 17:28:07 +0800
commitcfdad2793870d7034def686bf2a33eef2b72bae2 (patch)
treee1854f6141ec2762dfd8596077965b57e3df8158 /dev-libs
parentsys-fs/dosfstools: Don't link to udev via LDFLAGS. (diff)
downloadgentoo-cfdad2793870d7034def686bf2a33eef2b72bae2.tar.gz
gentoo-cfdad2793870d7034def686bf2a33eef2b72bae2.tar.bz2
gentoo-cfdad2793870d7034def686bf2a33eef2b72bae2.zip
dev-libs/uchardet: add live ebuild
It has EAPI=6. Package-Manager: portage-2.2.28 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/uchardet/uchardet-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/uchardet/uchardet-9999.ebuild b/dev-libs/uchardet/uchardet-9999.ebuild
new file mode 100644
index 000000000000..564cafba5466
--- /dev/null
+++ b/dev-libs/uchardet/uchardet-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="An encoding detector library ported from Mozilla"
+HOMEPAGE="https://github.com/BYVoid/uchardet"
+EGIT_REPO_URI="git://github.com/BYVoid/${PN}.git"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs test"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use test || cmake_comment_add_subdirectory test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}