summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-22 17:53:17 +0100
committerSam James <sam@gentoo.org>2023-04-22 17:53:17 +0100
commitd60d0beb9b2ca0afb938792dfd12599ca2c424d2 (patch)
treec7c17770d06cfb930acdddb40289fb3971829ac3 /dev-libs
parentnet-misc/rdesktop: fix configure w/ clang 16 (diff)
downloadgentoo-d60d0beb9b2ca0afb938792dfd12599ca2c424d2.tar.gz
gentoo-d60d0beb9b2ca0afb938792dfd12599ca2c424d2.tar.bz2
gentoo-d60d0beb9b2ca0afb938792dfd12599ca2c424d2.zip
dev-libs/chmlib: fix w/ clang 16
Closes: https://bugs.gentoo.org/871177 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/chmlib/chmlib-0.40-r2.ebuild (renamed from dev-libs/chmlib/chmlib-0.40-r1.ebuild)3
-rw-r--r--dev-libs/chmlib/files/chmlib-0.40-clang16.patch24
2 files changed, 26 insertions, 1 deletions
diff --git a/dev-libs/chmlib/chmlib-0.40-r1.ebuild b/dev-libs/chmlib/chmlib-0.40-r2.ebuild
index abdf79cf4f16..cdbdd764997e 100644
--- a/dev-libs/chmlib/chmlib-0.40-r1.ebuild
+++ b/dev-libs/chmlib/chmlib-0.40-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,6 +17,7 @@ IUSE="+examples static-libs"
PATCHES=(
"${FILESDIR}"/${PN}-0.39-stdtypes.patch
"${FILESDIR}"/${P}-headers.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {
diff --git a/dev-libs/chmlib/files/chmlib-0.40-clang16.patch b/dev-libs/chmlib/files/chmlib-0.40-clang16.patch
new file mode 100644
index 000000000000..eb66b91d5556
--- /dev/null
+++ b/dev-libs/chmlib/files/chmlib-0.40-clang16.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/871177
+https://github.com/jedwing/CHMLib/pull/17
+
+From 5877959e3eb9a54e131608c52e2d6f4c89bc0189 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Wed, 19 Apr 2023 09:47:03 +0200
+Subject: [PATCH] Avoid implicit function declarations, for C99 compatibility
+
+Define _LARGEFILE64_SOURCE so that <unistd.h> defines pread64.
+
+This avoids build failures with future compilers which do not
+support implicit function declarations by default.
+--- a/src/chm_lib.c
++++ b/src/chm_lib.c
+@@ -48,6 +48,8 @@
+ * *
+ ***************************************************************************/
+
++#define _LARGEFILE64_SOURCE /* for pread64 */
++
+ #include "chm_lib.h"
+
+ #ifdef CHM_MT
+