summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-12-21 19:10:29 +0100
committerPacho Ramos <pacho@gentoo.org>2021-12-21 19:25:03 +0100
commitdd8cb817ad5974e28ff5b62b4084177a31e2a70f (patch)
treec925d663c497d8d9b0e41b6128ba6514e51527dc /dev-libs
parentdev-python/sqlalchemy-rqlite: bump to version 1.1.1 (diff)
downloadgentoo-dd8cb817ad5974e28ff5b62b4084177a31e2a70f.tar.gz
gentoo-dd8cb817ad5974e28ff5b62b4084177a31e2a70f.tar.bz2
gentoo-dd8cb817ad5974e28ff5b62b4084177a31e2a70f.zip
dev-libs/satyr: Bump to 0.39
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/satyr/Manifest1
-rw-r--r--dev-libs/satyr/satyr-0.39.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-libs/satyr/Manifest b/dev-libs/satyr/Manifest
index 12fe8b7800d4..9969e66ff3ef 100644
--- a/dev-libs/satyr/Manifest
+++ b/dev-libs/satyr/Manifest
@@ -1 +1,2 @@
DIST satyr-0.38.tar.gz 433626 BLAKE2B 682d28a932758353e986d2906baf294183756d60a063ce03ba79506b58c92e4fc039c2246c0d43910f6d27d62dd674ffd3b772eeb6e8de46d8080735754b3d3a SHA512 09168050ca7bae00fb3d39f23f8c1e0adcf9cc4d3e491aa002bf9a0a7a265df980d12e430ea7f3eaa9010e0432821b106db5ce3b1e8d935d78b1e56d37110051
+DIST satyr-0.39.tar.gz 434581 BLAKE2B 7b4e11d8027877aa3b9e8144f8917f03b489b157c1112794a3c2bea9998a4367a7ec06cdec6c144fd96ecdabc83a85c5fb2644df02d59086ea3a113b1402fabe SHA512 f6d24ae054867ccdbb2dabdd63c6b351f7eec9ffe5426bdeffa86d585a52d13b07dd31e26b7d14e4850a1fdca748b0d5e23bb51fbc2843af79bf306f09d3145f
diff --git a/dev-libs/satyr/satyr-0.39.ebuild b/dev-libs/satyr/satyr-0.39.ebuild
new file mode 100644
index 000000000000..754906da9469
--- /dev/null
+++ b/dev-libs/satyr/satyr-0.39.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit autotools multiprocessing python-r1
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/4"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ >=dev-libs/elfutils-0.158
+ dev-libs/glib:2
+ dev-libs/json-c:=
+ dev-libs/nettle:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-util/gperf
+"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needs to be run before full autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-rpm
+ $(usex python "--with-python3" "--without-python3")
+ )
+
+ if use python; then
+ python_configure() {
+ econf "${myargs[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+
+}
+
+src_test() {
+ local extra_args
+
+ # In order to pass --jobs to the test runner
+ run_tests() {
+ cd tests || die
+ emake testsuite
+ ./testsuite --jobs=$(makeopts_jobs) ${extra_args[@]} $@
+
+ # Only run the python bindings tests for other python impls
+ extra_args=('-k' 'python3_bindings.*')
+ }
+
+ if use python; then
+ python_foreach_impl run_in_build_dir run_tests
+ else
+ run_tests SKIP_PYTHON3=yes
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}