summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-18 12:17:27 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-18 12:22:44 -0700
commite0d7c974595e37c05ebf8499f8e1a874c4a6f0c0 (patch)
tree9c066279021a0528b875c5ce61e7e6b25e34ea51 /dev-libs
parentdev-libs/libgee: Drop old versions (diff)
downloadgentoo-e0d7c974595e37c05ebf8499f8e1a874c4a6f0c0.tar.gz
gentoo-e0d7c974595e37c05ebf8499f8e1a874c4a6f0c0.tar.bz2
gentoo-e0d7c974595e37c05ebf8499f8e1a874c4a6f0c0.zip
dev-libs/libgit2: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgit2/Manifest1
-rw-r--r--dev-libs/libgit2/libgit2-1.4.0.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-libs/libgit2/Manifest b/dev-libs/libgit2/Manifest
index 84d6cf79a10f..9e5170dd0c03 100644
--- a/dev-libs/libgit2/Manifest
+++ b/dev-libs/libgit2/Manifest
@@ -1,4 +1,3 @@
DIST libgit2-1.3.0.tar.gz 5599575 BLAKE2B b701c105bb0a5bdcdd5ed1db180662ad4949c540944664d5d8c2f5d78998f15d15bd3669ae3e3d43bfa1b81207c0a94b7e49fc76e57f4cc8ef791ab26e62fc70 SHA512 842a648a67ff23ba9e6bf14b706ba9081164866e14000ebf3858442b7046925f05e1dbf00a7d740dc4bf32280e260730e23a9492e817094aa90736ae335ee76e
-DIST libgit2-1.4.0.tar.gz 5628993 BLAKE2B b28795904250474e0a373bb28f18f0a18c17c91c1597ad56eb44f8d47a8cb0aa6521b0599f427f34e477771116929db8d5bcafcb7aaf97ddc2534dfa3fd89525 SHA512 e7eff2e30a299901d7b4d9544b655046801e5c83b0caf1d2476ab56c164c88448dc189b254929f2609e117f01c2e038c4538e7554269ad93fbd625229668cd06
DIST libgit2-1.4.1.tar.gz 5629087 BLAKE2B 7c8316003c168c4b366fa4376d5e4dfa0a70dcb0cd0cc0b4ac7287f7b04eba50127cca89c4bcda94f86e5331b6a2951532b5108d5376a2a3fed7a68c31472151 SHA512 66943d82811c5e24687231696bd1ce8d7d58f44081c00a7030e01a69a7c920605a427c315a26af6c57c9bd7c1d1d31ab857f80615fce1ba4b981d01f733215cd
DIST libgit2-1.4.2.tar.gz 5629585 BLAKE2B 61e269fd08beb9579838a13b661b4270f1e8d2d3d1e67f6b8357e92a5ee4aaccbe637644dc87cc8b04d9c181e37808352077b75fed8753a4b2d8868eaf248b62 SHA512 144bec7f8e66d97b20335d87d1eb68d522f5e59064b0c557505c088d3c486d45704f023d701f51de572efa8e2eb111e3136eb5d23c035e29d16698206b5ec277
diff --git a/dev-libs/libgit2/libgit2-1.4.0.ebuild b/dev-libs/libgit2/libgit2-1.4.0.ebuild
deleted file mode 100644
index 0c7add69a35e..000000000000
--- a/dev-libs/libgit2/libgit2-1.4.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake python-any-r1
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.org"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S=${WORKDIR}/${P/_/-}
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~ppc-macos"
-IUSE="examples gssapi +ssh test +threads trace"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/libpcre:=
- net-libs/http-parser:=
- sys-libs/zlib
- dev-libs/openssl:0=
- gssapi? ( virtual/krb5 )
- ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-src_prepare() {
- cmake_src_prepare
- # relying on forked http-parser to support some obscure URI form
- sed -i -e '/empty_port/s:test:_&:' tests/network/url/parse.c || die
- # https://github.com/libgit2/libgit2/pull/6217
- sed -i -e 's:HTTP_Parser:HTTPParser:' cmake/SelectHTTPParser.cmake || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- -DUSE_SSH=$(usex ssh)
- -DUSE_GSSAPI=$(usex gssapi ON OFF)
- -DUSE_HTTP_PARSER=system
- -DREGEX_BACKEND=pcre
- )
- cmake_src_configure
-}
-
-src_test() {
- if [[ ${EUID} -eq 0 ]] ; then
- # repo::iterator::fs_preserves_error fails if run as root
- # since root can still access dirs with 0000 perms
- ewarn "Skipping tests: non-root privileges are required for all tests to pass"
- else
- local TEST_VERBOSE=1
- cmake_src_test -R offline
- fi
-}
-
-src_install() {
- cmake_src_install
- dodoc docs/*.{md,txt}
-
- if use examples ; then
- find examples -name '.gitignore' -delete || die
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}