summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-04-25 16:21:17 -0500
committerJoonas Niilola <juippis@gentoo.org>2022-04-27 12:41:27 +0300
commite40f9c59e293df44f1cae8ac2a28d7efec9fdd15 (patch)
tree2aaac52e1f7b4948ae976c12c5cdc2a8f572b04c /dev-libs
parentnet-im/zoom: remove old (diff)
downloadgentoo-e40f9c59e293df44f1cae8ac2a28d7efec9fdd15.tar.gz
gentoo-e40f9c59e293df44f1cae8ac2a28d7efec9fdd15.tar.bz2
gentoo-e40f9c59e293df44f1cae8ac2a28d7efec9fdd15.zip
dev-libs/libtpms: add 0.9.4
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libtpms/Manifest1
-rw-r--r--dev-libs/libtpms/libtpms-0.9.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libtpms/Manifest b/dev-libs/libtpms/Manifest
index 90ac3d3e08ab..1daa4b399f98 100644
--- a/dev-libs/libtpms/Manifest
+++ b/dev-libs/libtpms/Manifest
@@ -1 +1,2 @@
DIST libtpms-0.9.3.tar.gz 1263192 BLAKE2B a58cc2f76775f0a0a266cf6da898d6c8e310998c201dc47a802d67fc07dbe1632a68e81b78da68a6350e1d64727c7b47154479b4d9bc19a55324a2d881cad94f SHA512 8616c712f958c28a415b0a97a3a24f439f757682c4b60642584eb13e4ab2d7895838e8e6e57936ff583259506f9b379ec47c76d5780c1b257f25513a5911c3cb
+DIST libtpms-0.9.4.tar.gz 1264030 BLAKE2B 56731b913145afcd49fae13f0fcbe4fc147edf206a44849cef45ed34a7644f0894bb6ab5dcb72d620eb1ab121bf4e821fe7893557508af394585171133d659e2 SHA512 ae3e2613bc31d98c10def546c70d0c25bd1246af5090268afa0411502bfd0e454967046ebcd9025350976817441e595fa4e21562f800285db98331e4c2743505
diff --git a/dev-libs/libtpms/libtpms-0.9.4.ebuild b/dev-libs/libtpms/libtpms-0.9.4.ebuild
new file mode 100644
index 000000000000..fc15af9bf0f4
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.9.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-openssl
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 0.8.0; then
+ elog "Versions of libtpms prior to 0.8.0 generate weaker than expected TPM 2.0 RSA"
+ elog "keys due to a flawed key creation algorithm. Because fixing this would render"
+ elog "existing sealed data inaccessible, to use the corrected algorithm, the old"
+ elog "TPM state file must be deleted and a new TPM state file created. Data still"
+ elog "sealed using the old state file will be permanently inaccessible. For the"
+ elog "details see https://github.com/stefanberger/libtpms/issues/183"
+ fi
+}