summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-01-15 17:21:10 +0100
committerPacho Ramos <pacho@gentoo.org>2017-01-15 17:44:25 +0100
commite7d24a2a95e4b86431869c1ff1b6d17d52b80cd9 (patch)
tree7f67f34840eafe5cb727de7abef434decd4a0b8c /dev-libs
parentdev-libs/gmime: Version bump (diff)
downloadgentoo-e7d24a2a95e4b86431869c1ff1b6d17d52b80cd9.tar.gz
gentoo-e7d24a2a95e4b86431869c1ff1b6d17d52b80cd9.tar.bz2
gentoo-e7d24a2a95e4b86431869c1ff1b6d17d52b80cd9.zip
dev-libs/libgweather: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgweather/Manifest1
-rw-r--r--dev-libs/libgweather/libgweather-3.20.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/libgweather/Manifest b/dev-libs/libgweather/Manifest
index 091ebceb3b0a..0d47e606424c 100644
--- a/dev-libs/libgweather/Manifest
+++ b/dev-libs/libgweather/Manifest
@@ -1,2 +1,3 @@
DIST libgweather-3.18.2.tar.xz 3431224 SHA256 f35e52fa4023369ef5e04851311b3f15c9d7103ec801d0567eb3dec5851e71e3 SHA512 6e5ef37a50b22bb3941b703046bfcec78c6fd29aad3084c1a707a37f0418bc61c4852aa34501daaf20f6796e528a7ece948092b224d6f696b9d9e856fc384991 WHIRLPOOL 58f3d6a0c9acd4460a50077147ca9429a216777b402530632d922b38b9a47dd750b136be377cd3382de4638fa85bbab888a2356539f56e8f68a1787d346f459e
DIST libgweather-3.20.3.tar.xz 3376700 SHA256 fb6bc5b64ef5db3dc40a9798f072b83ebcafe7ff5af472aaee70600619b56c0b SHA512 feaf5a3ec5766934e482224cc4ca970db49c86addaabcae623d3ac1cadc7dc4a4759cb88552af7e92124f52a7a921ceef94759509cdc3e1fe20c749531ef7ad9 WHIRLPOOL 5e569741a3e75929d7bdba2e3aa69fc42df9472ecc6626e5f7b95a12dad9d5d5af9a87b73417056b54192b9a0ca47076a21cc18ad5c81a6fd349edaa1b5f7537
+DIST libgweather-3.20.4.tar.xz 3342220 SHA256 7dcdc555c48461d07a198bc44e0e6ed39105d8513b12fa97c4590f5b2d912fc2 SHA512 65b28a2bf8e9e7d8b02972d1d2f701ac8668b1e91154ba7ee94e9a08bb98d28ce44e88842e2fe78a13ce9f942d79fd2950d8de266dae28bb262c5fc11328ada9 WHIRLPOOL f01170d5e7790c22b1bfba8b6cd0e7b90708a818be2dc12a698e5ab4babb3efb6dfc368d7538b546a893a1b17b11ed04ebb0050c62b368f8f354ad9102b3c6e8
diff --git a/dev-libs/libgweather/libgweather-3.20.4.ebuild b/dev-libs/libgweather/libgweather-3.20.4.ebuild
new file mode 100644
index 000000000000..fb17cb8d77fe
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.20.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-6" # subslot = 3-(libgweather-3 soname suffix)
+
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-3.13.5:3[introspection?]
+ >=dev-libs/glib-2.35.1:2
+ >=net-libs/libsoup-2.44:2.4
+ >=dev-libs/libxml2-2.6.0:2
+ sci-geosciences/geocode-glib
+ >=sys-libs/timezone-data-2010k
+
+ glade? ( >=dev-util/glade-3.16:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-applets-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}