summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Fischl <github@fischl-online.de>2023-09-29 18:03:00 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2023-09-29 11:49:58 -0500
commitf090fbb91eda6d5d6b4b354631d6b8ab6d651188 (patch)
tree9af4a340bb1fd28826d98b5a27ee58358a5ff00a /dev-libs
parentdev-libs/icinga-php-library: add 0.13.0 (diff)
downloadgentoo-f090fbb91eda6d5d6b4b354631d6b8ab6d651188.tar.gz
gentoo-f090fbb91eda6d5d6b4b354631d6b8ab6d651188.tar.bz2
gentoo-f090fbb91eda6d5d6b4b354631d6b8ab6d651188.zip
dev-libs/icinga-php-thirdparty: add 0.12.0
Signed-off-by: Anton Fischl <github@fischl-online.de> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icinga-php-thirdparty/Manifest1
-rw-r--r--dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.12.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/icinga-php-thirdparty/Manifest b/dev-libs/icinga-php-thirdparty/Manifest
index e0fa0aea78f9..af9673e72790 100644
--- a/dev-libs/icinga-php-thirdparty/Manifest
+++ b/dev-libs/icinga-php-thirdparty/Manifest
@@ -1,2 +1,3 @@
DIST icinga-php-thirdparty-0.10.0.tar.gz 576508 BLAKE2B 3e07262415340c413bf79aa3031cf3679f0374c85dad9c41ffed78f65379837fc87df8433ea201b02455bde5c1fee1406f5b149b9d5b39cd726407657bdafb54 SHA512 3f5b6caad23860cecf5f06d165b01211af5284cb3dcb635bdcf4c2118b03c96de40a6d86cd0bccbe0f817ae87cc5d09aa2709ca90f55b948cf975c69dc234e95
DIST icinga-php-thirdparty-0.11.0.tar.gz 764914 BLAKE2B b9fbe66252edf5f504feab16392c60f4edf142d3644d13c29ba4f0291df40f8b4e3163f6bb97d944827a8a3d88728b5bf1c05ad193a078f889ba917714746c00 SHA512 5a2b9218a0426de6b560845db36e8e113a8be786eaf4ab57ff4f5e0ef485dc426cb0f203b4b45c3b791adb852098b64f2a0099c9909506594502edb2b4d4ee35
+DIST icinga-php-thirdparty-0.12.0.tar.gz 14204157 BLAKE2B f8a084cf0299dcca2e90ef97982c46d38f8ccd1c25d87e7106b22f4b91f49f9bbed8c31bf51af10083be28283d93be8d54c083450fd9563f4cc09cf35cdb270a SHA512 c087261712d486fba026128d7fd06590e824024d192d4d5feea902dbdb7134fca7b0e1d82aa4a5246859ca55303a6aed40a57b5aaf37e6652abb68549c8c48ea
diff --git a/dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.12.0.ebuild b/dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.12.0.ebuild
new file mode 100644
index 000000000000..72aaf1dbf4fe
--- /dev/null
+++ b/dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.12.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Icinga PHP libraries for Icinga Web 2"
+HOMEPAGE="https://github.com/Icinga/icinga-php-thirdparty"
+SRC_URI="https://github.com/Icinga/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/php:*"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ insinto "/usr/share/icinga-php/vendor"
+ cd "${S}"
+ doins -r *
+}