summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-09-23 19:45:42 -0700
committerMatt Turner <mattst88@gentoo.org>2021-09-23 19:54:26 -0700
commitf8f8419441a761acbe86a2c5a2c9d7db54461122 (patch)
tree1b2a18fa3cdbddaf698c019b0fe3a9dc363a5989 /dev-libs
parentapp-admin/ansible: we use new ansible now (diff)
downloadgentoo-f8f8419441a761acbe86a2c5a2c9d7db54461122.tar.gz
gentoo-f8f8419441a761acbe86a2c5a2c9d7db54461122.tar.bz2
gentoo-f8f8419441a761acbe86a2c5a2c9d7db54461122.zip
dev-libs/wayland-protocols: Version bump to 1.23
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.23.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 992d69b16890..526aa495c777 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,2 +1,3 @@
DIST wayland-protocols-1.21.tar.xz 117296 BLAKE2B 91dbfea6045e981fe94172fd13b74b150b0585560c06ad6990cfc57e02c97a013428431de54b196b4ed16db43724aae56f57dffb2b3f21615fe5522fe33aedc8 SHA512 40133ba36d4201de9626e9869ebdf2d4f7ad06904d6a747d5af87958a08368abdc65be3acc21b8959d0c5ec37d47051ba5b81d3844079fe237dac81a7291bbb8
DIST wayland-protocols-1.22.tar.xz 120084 BLAKE2B 955c35906757e60b434c53f0748d608f49c9061ddf148475a15d524896543f0498eb3e768fa1ddde82f60051a24b74d92733278f96a352971853b3bdcf4ad27d SHA512 fd69b33ab81d0f7b3b96b03bf820a80fdd8d6f5854c2851e4b72a69d7133fc136dde7a3c6b0d67856230ff40ee26dedf6157236897c7ba239d1e3ce32e9a22c7
+DIST wayland-protocols-1.23.tar.xz 74116 BLAKE2B a92f9d80e8d9062fb79c06e13141b46e0f43d0813f461e087a9fa724fa752df3b4fe5698e34e7431f3b43cca0adf7b86ab77c948060f6c02e4c7693f7975cd15 SHA512 11f09147da1dd01a9f5c921eb0bfc6244a72023a052ef96bc121e16437a2c43d0dbba748c2de832539f57371e90b16bd13069bec07391305717f8fca295ea2a6
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.23.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.23.ebuild
new file mode 100644
index 000000000000..f9b1910a51a1
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.23.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}