summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-06-30 12:48:13 -0400
committerBrian Evans <grknight@gentoo.org>2016-06-30 12:59:48 -0400
commitfa0e587e1a06c111db3b3991d402fb5a331f911c (patch)
tree9b9601b9e2cb8b69e8603e8ae703b5d5bee63cb1 /dev-libs
parentdev-libs/libbson: Version bump (diff)
downloadgentoo-fa0e587e1a06c111db3b3991d402fb5a331f911c.tar.gz
gentoo-fa0e587e1a06c111db3b3991d402fb5a331f911c.tar.bz2
gentoo-fa0e587e1a06c111db3b3991d402fb5a331f911c.zip
dev-libs/mongo-c-driver: Version bump
Non-maintainer commit; ack'd by Ultrabug in #gentoo-dev Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mongo-c-driver/Manifest1
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-1.3.5.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-libs/mongo-c-driver/Manifest b/dev-libs/mongo-c-driver/Manifest
index 03a1ea311182..92fb979e4607 100644
--- a/dev-libs/mongo-c-driver/Manifest
+++ b/dev-libs/mongo-c-driver/Manifest
@@ -3,3 +3,4 @@ DIST mongo-c-driver-0.8.1.tar.gz 124053 SHA256 9575f05fa87fe1f7c6562b1ec9202fd4b
DIST mongo-c-driver-0.98.2.tar.gz 5342760 SHA256 ac0edebd6ee55ac5c63047addc67d1801440586e6a9388cb3938c5bb0319afc5 SHA512 6e3abc31b1e0e02d3bb864882444a95aa01ec4a85ee77abdc52675a730790be7f1924f3c6ea36405ff0f2066e332302ca567bbfa35ba7b918bce81fb409600eb WHIRLPOOL 931a20b916778fcff0d419a73e1263b72b3293ce320254b050ed2211b56449e5e8dcd608459dcce8af98922e64a4aefc2908883f12a590d9e3e754573aed17c1
DIST mongo-c-driver-1.1.10.tar.gz 5321144 SHA256 19c076fcca1e7b22a731f10b757a049fd94b4aee6bbd0d7b7a0bcbd454e9dee8 SHA512 10ebd1bddc0c713c0934679974fb1ed29eda1bf8e2ebbe2a1ebbcba219574092c34c4b352231ec65ffe3e350d8d701ef85debaaa9f9c10e6ab36fc3fa29f69df WHIRLPOOL ee42e78fbab15b964a04ec70c4a782bb7cd0c46275619b46d32b2c00094df90e3de4a756e6f8496fec87a596af23a403d3cf33b391309e8a044334cbaec58a06
DIST mongo-c-driver-1.1.2.tar.gz 5443153 SHA256 ba97f4304883abf6d57ac96751260c4b413b871b0779c12e67136320bee5f118 SHA512 d420fc407f6a04c06a959b8971dc2643c987df5c3d82f2b13bfdf6a44e96bc377478c4d0e385abf67f21b56892c915c79675fe9ebf6efa9aab51fe452c5e6f95 WHIRLPOOL d72bdd7e449e8437bc9742e5f0330e6f6c47d40e3fc07a17d95a9967ecb2ae5961f5c7c155e2d8a12e733139ffbf30091dfa283f6f6a694e05c9c9fb7a03bd2b
+DIST mongo-c-driver-1.3.5.tar.gz 5860804 SHA256 374d37a6d6e49fbb2ed6cab0a305ced347651ec04d57808961d03afa8caa68df SHA512 23844ffe20580998308aa9c8409afcb87dccde874077eefc6806b705e5de5743846ba0513f3a3fe83147fc47842ab8c7438ad1de5f3f55b81586b9e19046aabf WHIRLPOOL 6583ba6e93e15ba025232bed1bb1964e85a90695d340d14c873fee26c0c9229d66eb1acfe53e718957210c2dbec67bfc06a1b7b95a9ed4dce0fe8cdad138ac6e
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.3.5.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-1.3.5.ebuild
new file mode 100644
index 000000000000..1d04a467a362
--- /dev/null
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-1.3.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A high-performance MongoDB driver for C"
+HOMEPAGE="https://github.com/mongodb/mongo-c-driver"
+SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug examples libressl sasl ssl static-libs test"
+
+RDEPEND=">=dev-libs/libbson-1.3.5
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}
+ test? ( dev-db/mongodb )"
+
+DOCS=( NEWS README.rst )
+
+src_prepare() {
+ rm -r src/libbson || die
+ sed -i -e '/SUBDIRS/s:src/libbson::g' Makefile.am || die
+
+ # https://github.com/mongodb/mongo-c-driver/issues/54
+ sed -i -e "s/PTHREAD_LIBS/PTHREAD_CFLAGS/g" src/Makefile.am \
+ tests/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-libbson=system \
+ --disable-hardening \
+ --disable-optimizations \
+ --disable-examples \
+ --docdir="${EPREFIX}/usr/share/doc/${P}" \
+ $(use_enable sasl) \
+ $(use_enable ssl ssl openssl) \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default_src_install
+ if [[ -f "${D}usr/share/doc/${P}/COPYING" ]] ; then
+ rm "${D}usr/share/doc/${P}/COPYING" || die
+ fi
+ # Only install the mongoc man pages to avoid conflicts of common names
+ doman doc/man/mongoc_*.3
+
+ use static-libs || find "${D}" -name '*.la' -delete
+
+ if use examples; then
+ insinto /usr/share/${PF}/examples
+ doins -r examples/*.c examples/aggregation examples/bulk
+ fi
+}
+
+src_test() {
+ # Avoid allocating too much disk space by using server.smallFiles = 1
+ echo -e "storage:\n smallFiles: true" > "${T}/mongod.conf"
+ local PORT=27099
+ mongod --port ${PORT} --bind_ip 127.0.0.1 --nounixsocket --fork \
+ -f "${T}/mongod.conf" --dbpath="${T}" \
+ --logpath="${T}/mongod.log" || die
+ MONGOC_TEST_HOST="127.0.0.1:${PORT}" emake test
+ kill `cat "${T}/mongod.lock"`
+}