summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-08-27 16:15:02 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-08-27 16:15:02 +0200
commitb361967eb47c88cdaf310c8fa459bccd5e672e7d (patch)
tree0a3071785f2b3dba8a24a00f36391e20bcaebb61 /dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild
parentmedia-video/vdr: glibc-2.24 deprecated warning fixed (diff)
downloadgentoo-b361967eb47c88cdaf310c8fa459bccd5e672e7d.tar.gz
gentoo-b361967eb47c88cdaf310c8fa459bccd5e672e7d.tar.bz2
gentoo-b361967eb47c88cdaf310c8fa459bccd5e672e7d.zip
dev-lisp/cl-ppcre: Bump version to 2.1.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild')
-rw-r--r--dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild b/dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild
new file mode 100644
index 000000000000..70c99953770f
--- /dev/null
+++ b/dev-lisp/cl-ppcre/cl-ppcre-2.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
+HOMEPAGE="http://weitz.de/cl-ppcre/
+ http://www.cliki.net/cl-ppcre"
+SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lisp/flexi-streams"
+PDEPEND="dev-lisp/cl-ppcre-unicode"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+ rm -rf cl-ppcre-unicode test/unicode*
+}
+
+src_install() {
+ common-lisp-install-sources *.lisp test/
+ common-lisp-install-asdf ${PN}
+ dodoc CHANGELOG docs/index.html
+}