summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso Josa <nimiux@gentoo.org>2015-12-17 23:16:55 +0100
committerJosé María Alonso Josa <nimiux@gentoo.org>2015-12-17 23:16:55 +0100
commitec1ac2389a1a20ff79b91f712f00d5fa21074011 (patch)
treebc504a0c62d343ce7d6a764218d7ad8b8677fe8e /dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild
parentx11-plugins/wmudmount: require USE=png on imagemagick (diff)
downloadgentoo-ec1ac2389a1a20ff79b91f712f00d5fa21074011.tar.gz
gentoo-ec1ac2389a1a20ff79b91f712f00d5fa21074011.tar.bz2
gentoo-ec1ac2389a1a20ff79b91f712f00d5fa21074011.zip
dev-lisp/cl-unicode: add from lisp overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild')
-rw-r--r--dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild b/dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild
new file mode 100644
index 000000000000..acc5def6a81d
--- /dev/null
+++ b/dev-lisp/cl-unicode/cl-unicode-0.1.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit common-lisp-3
+
+MY_P="v${PV}"
+
+DESCRIPTION="A library which provides Common Lisp implementations with knowledge about Unicode characters."
+HOMEPAGE="http://weitz.de/cl-unicode/"
+SRC_URI="https://github.com/edicl/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/flexi-streams"
+RDEPEND="dev-lisp/cl-ppcre"
+
+COMMONLISPS="sbcl clisp clozurecl cmucl ecls openmcl"
+
+find-lisp-impl() {
+ for lisp in ${COMMONLISPS} ; do
+ [[ "$(best_version dev-lisp/${lisp})" ]] && echo "${lisp}" && return
+ done
+ die "No CommonLisp implementation found"
+}
+
+src_compile() {
+ # cl-unicode builds parts of its source code automatically the first time it
+ # is compiled, so we compile it here.
+ local lispimpl=$(find-lisp-impl)
+ local initclunicode="(progn (push \"${S}/\" asdf:*central-registry*) (require :${PN}))"
+ common-lisp-export-impl-args "${lispimpl}"
+ ${lispimpl} ${CL_EVAL} "${initclunicode}"
+}
+
+src_install() {
+ common-lisp-install-sources *.lisp test/
+ common-lisp-install-sources -t all build/
+ common-lisp-install-asdf
+ dodoc CHANGELOG
+ dohtml doc/index.html
+}