summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-12-20 14:47:21 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-12-20 20:45:48 +0100
commited15a3659f8c2ea22790b7409966a019c555b134 (patch)
treee53c143d240959f9e1a42e37183b21d5056572cd /dev-lisp/flexi-streams
parentapp-emacs/indent-bars: add new dependency for 0.2 - compat (diff)
downloadgentoo-ed15a3659f8c2ea22790b7409966a019c555b134.tar.gz
gentoo-ed15a3659f8c2ea22790b7409966a019c555b134.tar.bz2
gentoo-ed15a3659f8c2ea22790b7409966a019c555b134.zip
dev-lisp/flexi-streams: add 1.0.19
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/34383 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lisp/flexi-streams')
-rw-r--r--dev-lisp/flexi-streams/Manifest1
-rw-r--r--dev-lisp/flexi-streams/flexi-streams-1.0.19.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-lisp/flexi-streams/Manifest b/dev-lisp/flexi-streams/Manifest
index 0c149de3b037..2c10e3f67e50 100644
--- a/dev-lisp/flexi-streams/Manifest
+++ b/dev-lisp/flexi-streams/Manifest
@@ -1,2 +1,3 @@
DIST flexi-streams-1.0.16.tar.gz 135698 BLAKE2B 9d6d5b064f10d27ce60d5a8a6792b7c36e63d393f64c98148bfd9addd36483e1e4d9e2b699c0ae151c55d88e01bd86fea3197e082b001face2c44206229c3e21 SHA512 66b7c5231616c7a6095a52d6c679717795c9308e33487536a5e1b7f0d25f26aacd2579a76c351f8e16a967a0611456cbc97b3824f4d9cf4875b8e48b0c4f7c78
DIST flexi-streams-1.0.17.tar.gz 135883 BLAKE2B 96670bffc8b53196d2138bff6bdcaaae74d3a9318bb637cb52914de0905be86d3d5ce40ed3f5f87deec75cbad609d339fc0656f8542ee05edae5c9c342430a90 SHA512 58a19214f74e00948dd5c15453cb68a65ad600a78fd7b637018914446a3953f68efa5e229b3d27e93464d8f273e82aa71d0fafe9b2ace77e40d23c5aea756d49
+DIST flexi-streams-1.0.19.tar.gz 393330 BLAKE2B 755f835ea7fe7edf0fd4ff317463a7ed86289aad428b4bbf461808900a9656711279de362a48c32d5ea8cb9933743b92c28729ad866950200d5d65bd7fab83c1 SHA512 03288868f86ce8c3c4ed63fb5f5f9d809bc0772834ef603793c861d09ad7ffb900c14021f1f1621111e7bd4ee3f0b0653985449391ee250d0f43385abbfdfdfa
diff --git a/dev-lisp/flexi-streams/flexi-streams-1.0.19.ebuild b/dev-lisp/flexi-streams/flexi-streams-1.0.19.ebuild
new file mode 100644
index 000000000000..6bac229dee34
--- /dev/null
+++ b/dev-lisp/flexi-streams/flexi-streams-1.0.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit common-lisp-3
+
+DESCRIPTION="Flexible bivalent streams for Common Lisp"
+HOMEPAGE="
+ http://weitz.de/flexi-streams/
+ http://www.cliki.net/flexi-streams/
+"
+SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lisp/trivial-gray-streams-20060925
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+src_test() {
+ local -x CL_SOURCE_REGISTRY="${S}:${CLSYSTEMROOT}"
+ common-lisp-export-impl-args $(common-lisp-find-lisp-impl)
+
+ ${CL_BINARY} ${CL_EVAL} "(asdf:test-system :flexi-streams)" || die
+}
+
+src_install() {
+ common-lisp-install-sources *.lisp
+ common-lisp-install-asdf
+ dodoc docs/index.html
+}