summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2016-03-19 07:24:23 -0700
committerIan Delaney <idella4@gentoo.org>2016-03-20 07:44:24 +0800
commit5571e2061e224eface490199a5988012d7d45659 (patch)
treeee7fbd8180a8313cf7d21652e30452a7c54b9437 /dev-lisp/sbcl/sbcl-1.3.3.ebuild
parentdev-lisp/sbcl: Removing outdated versions (diff)
downloadgentoo-5571e2061e224eface490199a5988012d7d45659.tar.gz
gentoo-5571e2061e224eface490199a5988012d7d45659.tar.bz2
gentoo-5571e2061e224eface490199a5988012d7d45659.zip
dev-lisp/sbcl: Updating ebuilds to EAPI 6
Updating sbcl-1.3.* to EAPI 6 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1085
Diffstat (limited to 'dev-lisp/sbcl/sbcl-1.3.3.ebuild')
-rw-r--r--dev-lisp/sbcl/sbcl-1.3.3.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/dev-lisp/sbcl/sbcl-1.3.3.ebuild b/dev-lisp/sbcl/sbcl-1.3.3.ebuild
index edd65ba3fe68..b6f12913dab4 100644
--- a/dev-lisp/sbcl/sbcl-1.3.3.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.3.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit multilib eutils flag-o-matic pax-utils
#same order as http://www.sbcl.org/platform-table.html
@@ -94,23 +94,25 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/gentoo-fix_install_man.patch
+ eapply "${FILESDIR}"/gentoo-fix_install_man.patch
# bug #468482
- epatch "${FILESDIR}"/concurrency-test-1.2.6.patch
+ eapply "${FILESDIR}"/concurrency-test-1.2.6.patch
# bugs #486552, #527666, #517004
- epatch "${FILESDIR}"/bsd-sockets-test-1.2.11.patch
+ eapply "${FILESDIR}"/bsd-sockets-test-1.2.11.patch
# bugs #560276, #561018
- epatch "${FILESDIR}"/sb-posix-test-1.2.15.patch
+ eapply "${FILESDIR}"/sb-posix-test-1.2.15.patch
- epatch "${FILESDIR}"/${PN}-1.2.11-solaris.patch
- epatch "${FILESDIR}"/${PN}-1.2.13-verbose-build.patch
+ eapply "${FILESDIR}"/${PN}-1.2.11-solaris.patch
+ eapply "${FILESDIR}"/${PN}-1.2.13-verbose-build.patch
# To make the hardened compiler NOT compile with -fPIE -pie
if gcc-specs-pie ; then
einfo "Disabling PIE..."
- epatch "${FILESDIR}"/${PN}-1.1.17-gentoo-fix_nopie_for_hardened_toolchain.patch
+ eapply "${FILESDIR}"/${PN}-1.1.17-gentoo-fix_nopie_for_hardened_toolchain.patch
fi
+ eapply_user
+
# bug #526194
sed -e "s@CFLAGS =.*\$@CFLAGS = ${CFLAGS} -g -Wall -Wsign-compare@" \
-e "s@LINKFLAGS =.*\$@LINKFLAGS = ${LDFLAGS} -g@" \
@@ -215,11 +217,15 @@ src_install() {
find "${ED}" -empty -type d -exec rmdir -v {} +
if use doc; then
- dohtml -r doc/manual/
+ docinto html
+ dodoc -r doc/manual/
+ dodoc -r doc/internals/sbcl-internals
+
doinfo doc/manual/*.info*
- dohtml -r doc/internals/sbcl-internals
doinfo doc/internals/sbcl-internals.info
- docinto internals-notes && dodoc doc/internals-notes/*
+
+ docinto internals-notes
+ dodoc doc/internals-notes/*
else
rm -Rv "${ED}/usr/share/doc/${PF}" || die
fi