summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-13 00:38:23 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-13 22:07:01 +0100
commit2815f3334138d1fe41230797fac3fd704299a23b (patch)
tree74bf197fdb4b8ea57f0b0720cbcdf386ebf5b116 /dev-lisp
parentdev-lisp/cmucl: fix DeprecatedInsinto (diff)
downloadgentoo-2815f3334138d1fe41230797fac3fd704299a23b.tar.gz
gentoo-2815f3334138d1fe41230797fac3fd704299a23b.tar.bz2
gentoo-2815f3334138d1fe41230797fac3fd704299a23b.zip
dev-lisp/gcl: fix DeprecatedInsinto
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/gcl/gcl-2.6.10.ebuild11
-rw-r--r--dev-lisp/gcl/gcl-2.6.12.ebuild11
2 files changed, 10 insertions, 12 deletions
diff --git a/dev-lisp/gcl/gcl-2.6.10.ebuild b/dev-lisp/gcl/gcl-2.6.10.ebuild
index 0216a90d7973..a56cb2c6f6bf 100644
--- a/dev-lisp/gcl/gcl-2.6.10.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -8,6 +8,7 @@ inherit elisp-common epatch flag-o-matic
DESCRIPTION="GNU Common Lisp"
HOMEPAGE="https://www.gnu.org/software/gcl/gcl.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz https://dev.gentoo.org/~grozin/${P}-fedora.tar.bz2"
+S="${WORKDIR}"/${PN}
LICENSE="LGPL-2 GPL-2"
SLOT="0"
@@ -29,8 +30,6 @@ DEPEND="${RDEPEND}
>=app-text/texi2html-1.64
>=sys-devel/autoconf-2.52"
-S="${WORKDIR}"/${PN}
-
src_prepare() {
mv "${WORKDIR}"/fedora/info/* info/
cp -p /usr/share/texmf-dist/tex/texinfo/texinfo.tex info/
@@ -135,11 +134,11 @@ src_install() {
fi
insinto /usr/share/doc/${PF}
- doins *.dvi
+ docompress -x /usr/share/doc/${PF}/*.dvi
if use athena; then
pushd xgcl-2 > /dev/null
- insinto /usr/share/doc/${PF}
- doins *.pdf
+ dodoc *.pdf
+ docompress -x /usr/share/doc/${PF}/*.pdf
popd > /dev/null
fi
}
diff --git a/dev-lisp/gcl/gcl-2.6.12.ebuild b/dev-lisp/gcl/gcl-2.6.12.ebuild
index 33b27a39d040..014ccda2e8ac 100644
--- a/dev-lisp/gcl/gcl-2.6.12.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -7,6 +7,7 @@ inherit elisp-common epatch flag-o-matic
DESCRIPTION="GNU Common Lisp"
HOMEPAGE="https://www.gnu.org/software/gcl/gcl.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz https://dev.gentoo.org/~grozin/${P}-fedora.tar.bz2"
+S="${WORKDIR}"/${PN}
LICENSE="LGPL-2 GPL-2"
SLOT="0"
@@ -28,8 +29,6 @@ DEPEND="${RDEPEND}
>=app-text/texi2html-1.64
>=sys-devel/autoconf-2.52"
-S="${WORKDIR}"/${PN}
-
src_prepare() {
mv "${WORKDIR}"/fedora/info/* info/
cp -p /usr/share/texmf-dist/tex/texinfo/texinfo.tex info/
@@ -131,11 +130,11 @@ src_install() {
fi
insinto /usr/share/doc/${PF}
- doins info/*.pdf
+ docompress -x /usr/share/doc/${PF}/*.dvi
if use athena; then
pushd xgcl-2 > /dev/null
- insinto /usr/share/doc/${PF}
- doins *.pdf
+ dodoc *.pdf
+ docompress -x /usr/share/doc/${PF}/*.pdf
popd > /dev/null
fi
}