summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-06-22 12:25:38 +0200
committerUlrich Müller <ulm@gentoo.org>2021-06-22 12:27:35 +0200
commit561bda218a15bf372255b197fcc00684ae38fd43 (patch)
treecd2c45802f22ef3df4a7d0020aab712f73e8d6cf /dev-lisp
parentdev-libs/openssl: export $CXX (diff)
downloadgentoo-561bda218a15bf372255b197fcc00684ae38fd43.tar.gz
gentoo-561bda218a15bf372255b197fcc00684ae38fd43.tar.bz2
gentoo-561bda218a15bf372255b197fcc00684ae38fd43.zip
dev-lisp/sbcl: Drop pax_kernel support
This is no longer a supported configuration: https://archives.gentoo.org/gentoo-dev/message/0283ed6004111127e0e575cc912feff1 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/metadata.xml3
-rw-r--r--dev-lisp/sbcl/sbcl-1.3.11.ebuild14
-rw-r--r--dev-lisp/sbcl/sbcl-1.4.9.ebuild14
-rw-r--r--dev-lisp/sbcl/sbcl-2.0.10.ebuild14
-rw-r--r--dev-lisp/sbcl/sbcl-2.0.11.ebuild14
-rw-r--r--dev-lisp/sbcl/sbcl-2.1.0.ebuild14
-rw-r--r--dev-lisp/sbcl/sbcl-2.1.1.ebuild14
-rw-r--r--dev-lisp/sbcl/sbcl-2.1.2.ebuild14
-rw-r--r--dev-lisp/sbcl/sbcl-2.1.3.ebuild14
-rw-r--r--dev-lisp/sbcl/sbcl-2.1.4.ebuild14
-rw-r--r--dev-lisp/sbcl/sbcl-2.1.5.ebuild14
11 files changed, 20 insertions, 123 deletions
diff --git a/dev-lisp/sbcl/metadata.xml b/dev-lisp/sbcl/metadata.xml
index 031c80402d9d..c285e2f1de8d 100644
--- a/dev-lisp/sbcl/metadata.xml
+++ b/dev-lisp/sbcl/metadata.xml
@@ -19,9 +19,6 @@
available for the x86 and amd64 platforms using an NPTL enabled
GLIBC. SBCL 0.8.17 and later support Unicode.
</longdescription>
- <use>
- <flag name="pax_kernel">Enable if the user plans to run the package under a pax enabled hardened kernel</flag>
- </use>
<upstream>
<remote-id type="sourceforge">sbcl</remote-id>
</upstream>
diff --git a/dev-lisp/sbcl/sbcl-1.3.11.ebuild b/dev-lisp/sbcl/sbcl-1.3.11.ebuild
index ee07b9e0c5db..16623ac505ba 100644
--- a/dev-lisp/sbcl/sbcl-1.3.11.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.3.11.ebuild
@@ -36,12 +36,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.1:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -150,15 +149,6 @@ src_compile() {
strip-unsupported-flags ; filter-flags -fomit-frame-pointer
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-1.4.9.ebuild b/dev-lisp/sbcl/sbcl-1.4.9.ebuild
index df2d06a62003..b14abfe6e8db 100644
--- a/dev-lisp/sbcl/sbcl-1.4.9.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.4.9.ebuild
@@ -38,12 +38,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.1:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -157,15 +156,6 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.0.10.ebuild b/dev-lisp/sbcl/sbcl-2.0.10.ebuild
index a98127f960c3..5b10db5a631c 100644
--- a/dev-lisp/sbcl/sbcl-2.0.10.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.0.10.ebuild
@@ -38,12 +38,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.3:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -153,15 +152,6 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.0.11.ebuild b/dev-lisp/sbcl/sbcl-2.0.11.ebuild
index 7325503741de..8f97a4edc517 100644
--- a/dev-lisp/sbcl/sbcl-2.0.11.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.0.11.ebuild
@@ -38,12 +38,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.3:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -153,15 +152,6 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.1.0.ebuild b/dev-lisp/sbcl/sbcl-2.1.0.ebuild
index 0c5345f75186..d52ecf3e92bb 100644
--- a/dev-lisp/sbcl/sbcl-2.1.0.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.1.0.ebuild
@@ -38,12 +38,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.3:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -155,15 +154,6 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.1.1.ebuild b/dev-lisp/sbcl/sbcl-2.1.1.ebuild
index 5e9c763459d9..35d6414cdd24 100644
--- a/dev-lisp/sbcl/sbcl-2.1.1.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.1.1.ebuild
@@ -38,12 +38,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.3:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -155,15 +154,6 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.1.2.ebuild b/dev-lisp/sbcl/sbcl-2.1.2.ebuild
index f248e85eee02..24d9a683f21f 100644
--- a/dev-lisp/sbcl/sbcl-2.1.2.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.1.2.ebuild
@@ -38,12 +38,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.3:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -155,15 +154,6 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.1.3.ebuild b/dev-lisp/sbcl/sbcl-2.1.3.ebuild
index 7e4ebc2afb36..0ff92fe69f4f 100644
--- a/dev-lisp/sbcl/sbcl-2.1.3.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.1.3.ebuild
@@ -38,12 +38,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.3:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -155,15 +154,6 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.1.4.ebuild b/dev-lisp/sbcl/sbcl-2.1.4.ebuild
index 384c75715bdd..7e0a646d884f 100644
--- a/dev-lisp/sbcl/sbcl-2.1.4.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.1.4.ebuild
@@ -38,12 +38,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.3:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -155,15 +154,6 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.1.5.ebuild b/dev-lisp/sbcl/sbcl-2.1.5.ebuild
index 5b723d8bd15b..31722af3e2b1 100644
--- a/dev-lisp/sbcl/sbcl-2.1.5.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.1.5.ebuild
@@ -38,12 +38,11 @@ SRC_URI="mirror://sourceforge/sbcl/${P}-source.tar.bz2
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="debug doc source +threads +unicode pax_kernel zlib"
+IUSE="debug doc source +threads +unicode zlib"
CDEPEND=">=dev-lisp/asdf-3.3:="
DEPEND="${CDEPEND}
- doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )
- pax_kernel? ( sys-apps/elfix )"
+ doc? ( sys-apps/texinfo >=media-gfx/graphviz-2.26.0 )"
RDEPEND="${CDEPEND}
!prefix? ( elibc_glibc? ( >=sys-libs/glibc-2.6 ) )"
@@ -155,15 +154,6 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- if use pax_kernel ; then
- # To disable PaX on hardened systems
- pax-mark -mr "${bindir}"/src/runtime/sbcl
-
- # Hack to disable PaX on second GENESIS stage
- sed -i -e '/^[ \t]*echo \/\/doing warm init - compilation phase$/a\ paxmark.sh -mr \.\/src\/runtime\/sbcl' \
- "${S}"/make-target-2.sh || die "Cannot disable PaX on second GENESIS runtime"
- fi
-
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \