summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-02-25 22:13:53 +0100
committerUlrich Müller <ulm@gentoo.org>2021-02-25 22:14:07 +0100
commita76bba87122f587040ce2e1827fc043ac64d164e (patch)
tree4e98e31fd73b9f968a97073bf10ad117fdede12a /dev-lisp
parentapp-emacs/emacs-common-gentoo: Remove old (diff)
downloadgentoo-a76bba87122f587040ce2e1827fc043ac64d164e.tar.gz
gentoo-a76bba87122f587040ce2e1827fc043ac64d164e.tar.bz2
gentoo-a76bba87122f587040ce2e1827fc043ac64d164e.zip
dev-lisp/abcl: Version bump to 1.8.0
Bump EAPI to 7. Specify license more precisely, drop mirror restriction. Closes: https://bugs.gentoo.org/764710 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/abcl/Manifest1
-rw-r--r--dev-lisp/abcl/abcl-1.8.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-lisp/abcl/Manifest b/dev-lisp/abcl/Manifest
index 96ca2c285a73..ff80b92d4e96 100644
--- a/dev-lisp/abcl/Manifest
+++ b/dev-lisp/abcl/Manifest
@@ -1 +1,2 @@
DIST abcl-src-1.5.0.tar.gz 1187678 BLAKE2B 4c6993ab90d6fe12e93bf185ecdc16dd5c69ff5c65881e74db51ba9a8167e3a3de4b25ff9971084e92499f654aacec2a07757d100a5977944076476d47c17438 SHA512 d56c23a82103dfebb3361903af096f923738008e551f3b5e07e00f0423c8ade0b07a388b7834b5d79d9191863b38db2c17fa27bffd848d7cba88d6bb67e32db3
+DIST abcl-src-1.8.0.tar.gz 2613411 BLAKE2B cd50e5df0b7e48c902bc904ca4ea0e9c293241e04cfda154cb388c5f58da921645333fca8e0a95768a550fcb2a5b6346b3e8958745138ea6826f5c5a62ef0faf SHA512 90cc2d1e52a4dc83a0159a5763d2c7eb344952786a805a82180e0000a0cae26d89ae5a9293b629b7b5131eac05668fe21711abca32aebe05d7400187b0b3793b
diff --git a/dev-lisp/abcl/abcl-1.8.0.ebuild b/dev-lisp/abcl/abcl-1.8.0.ebuild
new file mode 100644
index 000000000000..139a56a5ef2d
--- /dev/null
+++ b/dev-lisp/abcl/abcl-1.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P=${PN}-src-${PV}
+
+DESCRIPTION="Armed Bear Common Lisp is a Common Lisp implementation for the JVM."
+HOMEPAGE="http://common-lisp.net/project/armedbear/"
+SRC_URI="http://abcl.org/releases/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2-with-classpath-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ eant abcl.compile || die "Can't compile ABCL"
+ eant abcl.jar || die "Can't make ABCL jar archive"
+}
+
+src_install() {
+ java-pkg_dojar dist/abcl.jar
+ java-pkg_dolauncher ${PN} --java_args "-server -Xrs" --main org.armedbear.lisp.Main
+ dodoc README
+}