summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber+gentoo@sysrq.in>2021-12-18 14:18:37 +0500
committerSam James <sam@gentoo.org>2022-05-13 19:30:42 +0000
commitec5d27c4ea0e7d3def7d369b84eb0373d02d529d (patch)
tree4c25b20cdef1de4ddf1de229e5dc2c800e409799 /dev-lisp
parentnet-analyzer/sslscan: respect toolchain environment (diff)
downloadgentoo-ec5d27c4ea0e7d3def7d369b84eb0373d02d529d.tar.gz
gentoo-ec5d27c4ea0e7d3def7d369b84eb0373d02d529d.tar.bz2
gentoo-ec5d27c4ea0e7d3def7d369b84eb0373d02d529d.zip
dev-lisp/alexandria: version bump to 1.4
Closes: https://bugs.gentoo.org/829538 Signed-off-by: Anna Vyalkova <cyber+gentoo@sysrq.in> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/alexandria/Manifest2
-rw-r--r--dev-lisp/alexandria/alexandria-1.4.ebuild39
-rw-r--r--dev-lisp/alexandria/alexandria-20171029.ebuild39
3 files changed, 40 insertions, 40 deletions
diff --git a/dev-lisp/alexandria/Manifest b/dev-lisp/alexandria/Manifest
index 646c8333fee8..300a98810ff7 100644
--- a/dev-lisp/alexandria/Manifest
+++ b/dev-lisp/alexandria/Manifest
@@ -1 +1 @@
-DIST alexandria-20171029.tar.bz2 45812 BLAKE2B 812f43483a0b25e4c4d481deec90ac1681a3c76062f5bf43b14530b239b2978e8d0cf735249b1093298db2761dc80a7d81e54da1e763db469b691b60d6db5d20 SHA512 a0a7386af94bae00139e3d06306169883cb1c5498c84d7a6db552a5dfa2ff8516d62609cb8a059c11f4200d507737ba99032d81b5a97112a2f3e7850572060e2
+DIST alexandria-v1.4.tar.gz 57634 BLAKE2B e552d44f0b4db326f09246f88af57ccd233dbb3b4354d2b9a55c8b9ddaf441016010fb4645f32ad0fbc82fb6755957fe7c989c67af62dd04f39baf78478e4b1c SHA512 4343be8eb2bac1924aaa8c890895aa885205af4c84110d7f8ceaf6c9ba1390e6037ffa3697fd1630266aede01bb596fd84c332ca43ded80326795637583332af
diff --git a/dev-lisp/alexandria/alexandria-1.4.ebuild b/dev-lisp/alexandria/alexandria-1.4.ebuild
new file mode 100644
index 000000000000..a7952b182691
--- /dev/null
+++ b/dev-lisp/alexandria/alexandria-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit common-lisp-3
+
+DESCRIPTION="A collection of portable utilities for Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/alexandria/ https://gitlab.common-lisp.net/alexandria/alexandria"
+SRC_URI="https://gitlab.common-lisp.net/${PN}/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+# sbcl is hardcoded in Makefile
+BDEPEND="doc? (
+ dev-lisp/sbcl
+ sys-apps/texinfo
+)
+"
+
+DOCS=( README AUTHORS )
+
+src_compile() {
+ use doc && emake -C doc
+}
+
+src_install() {
+ common-lisp-install-sources -t all alexandria-1 alexandria-2 LICENCE
+ common-lisp-install-asdf
+ if use doc; then
+ doinfo doc/${PN}.info
+ HTML_DOCS=( doc/{"${PN}.html","${PN}.pdf"} )
+ fi
+ einstalldocs
+}
diff --git a/dev-lisp/alexandria/alexandria-20171029.ebuild b/dev-lisp/alexandria/alexandria-20171029.ebuild
deleted file mode 100644
index 9d6ceebd20e6..000000000000
--- a/dev-lisp/alexandria/alexandria-20171029.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit common-lisp-3
-
-DESCRIPTION="A collection of portable utilities for Common Lisp"
-HOMEPAGE="http://common-lisp.net/project/alexandria/"
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.common-lisp.net/alexandria/alexandria.git"
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2"
- KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-fi
-
-LICENSE="public-domain"
-SLOT="0"
-IUSE="doc"
-
-DEPEND="doc? ( sys-apps/texinfo )"
-RDEPEND=""
-
-src_prepare() {
- eapply "${FILESDIR}/${PN}-fix-docstrings.patch"
- eapply_user
-}
-
-src_compile() {
- use doc && emake -C doc
-}
-
-src_install() {
- common-lisp-install-sources -t all *.lisp LICENCE
- common-lisp-install-asdf
- dodoc README AUTHORS
- use doc && doinfo doc/${PN}.info && dodoc doc/{"${PN}.html","${PN}.pdf"}
-}