summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:11:44 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:30 +0100
commit95663a7ef7a0ee0599950bf3330c6a800b44ce77 (patch)
tree5f08e5215664eb59f9dcc57e041e938d24bf258d /dev-lua/LuaBitOp
parentdev-lua/LuaBitOp: update EAPI 7 -> 8 (diff)
downloadgentoo-95663a7ef7a0ee0599950bf3330c6a800b44ce77.tar.gz
gentoo-95663a7ef7a0ee0599950bf3330c6a800b44ce77.tar.bz2
gentoo-95663a7ef7a0ee0599950bf3330c6a800b44ce77.zip
dev-lua/LuaBitOp: drop 1.0.2-r103
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/LuaBitOp')
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.2-r103.ebuild97
1 files changed, 0 insertions, 97 deletions
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r103.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r103.ebuild
deleted file mode 100644
index 70ede4e19327..000000000000
--- a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r103.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit flag-o-matic lua toolchain-funcs
-
-DESCRIPTION="Bit Operations Library for the Lua Programming Language"
-HOMEPAGE="http://bitop.luajit.org"
-SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~x64-macos"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "doc/." )
-
-PATCHES=( "${FILESDIR}/${P}-support-lua5-3+.patch" )
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "CCOPT="
- "INCLUDES=$(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}" all
-
- popd
-}
-
-src_compile() {
- if [[ $CHOST == *-darwin* ]] ; then
- append-ldflags "-undefined dynamic_lookup"
- fi
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
-
- local mytests=(
- "bitbench.lua"
- "bittest.lua"
- "md5test.lua"
- "nsievebits.lua"
- )
-
- for mytest in ${mytests[@]}; do
- LUA_CPATH="./?.so" ${ELUA} ${mytest}
- done
-
- popd
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- mycmoddir="$(lua_get_cmod_dir)"
- exeinto "${mycmoddir#$EPREFIX}"
- doexe bit.so
-
- popd
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- local luav=$(lua_get_version)
- # we only want the major version (e.g. 5.1)
- local luamv=${luav:0:3}
- local file="lua/${luamv}/bit.so"
- install_name_tool -id "${EPREFIX}/usr/$(get_libdir)/${file}" "${ED}/usr/$(get_libdir)/${file}" || die "Failed to adjust install_name"
- fi
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}