summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-30 13:29:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-30 14:32:53 +0100
commitb41f80eaebe323f6dec04b2b391f529986c7f7dd (patch)
treea46352267612441c3e245ea4c7be4077ea06d1ac /dev-lua/inifile/inifile-1.0-r100.ebuild
parentdev-lua/luassert: remove lua deps version requirement (diff)
downloadgentoo-b41f80eaebe323f6dec04b2b391f529986c7f7dd.tar.gz
gentoo-b41f80eaebe323f6dec04b2b391f529986c7f7dd.tar.bz2
gentoo-b41f80eaebe323f6dec04b2b391f529986c7f7dd.zip
dev-lua/inifile: new package
This is a simple ini parser for lua. It will serve as da lua dep for packages, which will get added tests and need that. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/inifile/inifile-1.0-r100.ebuild')
-rw-r--r--dev-lua/inifile/inifile-1.0-r100.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lua/inifile/inifile-1.0-r100.ebuild b/dev-lua/inifile/inifile-1.0-r100.ebuild
new file mode 100644
index 000000000000..89a8791ca127
--- /dev/null
+++ b/dev-lua/inifile/inifile-1.0-r100.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua
+
+DESCRIPTION="A simple and complete ini parser for Lua"
+HOMEPAGE="https://github.com/bartbes/inifile/"
+SRC_URI="https://github.com/bartbes/inifile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins inifile.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}