summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-01 21:38:40 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-03-01 21:46:05 +0100
commit3afbfd3e2e5b318058fc50480689254f00707e02 (patch)
tree5048ba6aa2b64c45821d37d156a4466d5974a52f /dev-lua/lanes
parentmedia-video/makemkv: Bump to 1.16.7, drop old 1.16.5 (diff)
downloadgentoo-3afbfd3e2e5b318058fc50480689254f00707e02.tar.gz
gentoo-3afbfd3e2e5b318058fc50480689254f00707e02.tar.bz2
gentoo-3afbfd3e2e5b318058fc50480689254f00707e02.zip
dev-lua/lanes: add 3.16.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lanes')
-rw-r--r--dev-lua/lanes/Manifest1
-rw-r--r--dev-lua/lanes/lanes-3.16.0.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-lua/lanes/Manifest b/dev-lua/lanes/Manifest
index ab12c3e594ec..585a5dc4b77f 100644
--- a/dev-lua/lanes/Manifest
+++ b/dev-lua/lanes/Manifest
@@ -1 +1,2 @@
DIST lanes-3.15.1.tar.gz 252057 BLAKE2B 36de0b85d6d7f43406249e4463c6560d3d539791700d4bd77cd366dd04b8cb672c5aff68c4409dd4e6b5df8ab93f6841c2168ecea9f4ea60768e42f3ffc543e9 SHA512 110528e3ffda5e721046f52a31d9cc707db4b7cca1a706d8c2e35b54d26375855f8ba52f4568c42caa2707da7c05ac1278460af185346bfd4fafdd7c237d256a
+DIST lanes-3.16.0.tar.gz 257945 BLAKE2B aecc0bd551f10b29791acdde8da30fb83591395eac4d152999a0e92fe9738a6171b13363edae2d94b1db47398a01e011833ccee7a7f234033d3230605423c0b6 SHA512 ffd935baae8af752591251bbb1a7f936034ad281870d453e6e1b4291c175c91537ccae23ec25a616b45e8ab601222f323e05e938d7887091ba7e132b0cd5e449
diff --git a/dev-lua/lanes/lanes-3.16.0.ebuild b/dev-lua/lanes/lanes-3.16.0.ebuild
new file mode 100644
index 000000000000..da2c983695a2
--- /dev/null
+++ b/dev-lua/lanes/lanes-3.16.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lightweight, native, lazy evaluating multithreading library"
+HOMEPAGE="https://github.com/LuaLanes/lanes"
+SRC_URI="https://github.com/LuaLanes/lanes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Tests are currently somehow problematic.
+# https://github.com/LuaLanes/lanes/issues/197
+# https://github.com/LuaLanes/lanes/issues/198
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+PATCHES=( "${FILESDIR}/${PN}-3.13.0-makefile.patch" )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LUA=${ELUA}"
+ "LUA_FLAGS=$(lua_get_CFLAGS)"
+ "LUA_LIBS="
+ "OPT_FLAGS=${CFLAGS}"
+ )
+
+ tc-export PKG_CONFIG
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+
+ emake LUA="${ELUA}" test
+
+ popd
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
+ "LUA_SHAREDIR=${ED}/$(lua_get_lmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}