summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-09-19 12:38:21 -0400
committerAaron Bauman <bman@gentoo.org>2020-09-19 12:40:11 -0400
commit317c751501b149576272010d6efbab174953f07d (patch)
tree455b34a0989fd4bcb8cd2b7648fb4c7c61c1055e /dev-lua/lgi/lgi-0.9.0.ebuild
parentdev-libs/clipper: Keyword 6.4.2 arm64, #734826 (diff)
downloadgentoo-317c751501b149576272010d6efbab174953f07d.tar.gz
gentoo-317c751501b149576272010d6efbab174953f07d.tar.bz2
gentoo-317c751501b149576272010d6efbab174953f07d.zip
dev-lua/lgi: drop old EAPI=4 and unstable ebuild
Closes: https://bugs.gentoo.org/704766 Closes: https://bugs.gentoo.org/679862 Closes: https://bugs.gentoo.org/628022 Closes: https://bugs.gentoo.org/662790 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-lua/lgi/lgi-0.9.0.ebuild')
-rw-r--r--dev-lua/lgi/lgi-0.9.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-lua/lgi/lgi-0.9.0.ebuild b/dev-lua/lgi/lgi-0.9.0.ebuild
deleted file mode 100644
index 51020ae52c96..000000000000
--- a/dev-lua/lgi/lgi-0.9.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-VIRTUALX_REQUIRED="manual"
-
-inherit eutils toolchain-funcs flag-o-matic virtualx
-
-DESCRIPTION="Lua bindings using gobject-introspection"
-HOMEPAGE="https://github.com/pavouk/lgi"
-SRC_URI="https://github.com/pavouk/lgi/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-lang/lua-5.1
- dev-libs/gobject-introspection
- dev-libs/glib
- virtual/libffi"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? (
- x11-libs/cairo[glib]
- x11-libs/gtk+[introspection]
- ${VIRTUALX_DEPEND}
- )"
-
-src_prepare() {
- sed -i \
- -e "s:^LUA_LIBDIR.*$:LUA_LIBDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua):" \
- -e "s:^LUA_SHAREDIR.*$:LUA_SHAREDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua):" \
- "${S}"/lgi/Makefile || die "sed failed"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}"
-}
-
-src_test() {
- Xemake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}" check
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dohtml -r docs/*
- dodoc README.md
- if use examples; then
- dodoc -r samples
- fi
-}