summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-11-28 14:51:00 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2020-11-28 15:12:08 -0800
commit1a6dc03ce8e11606e794ea6d187771e18432153c (patch)
tree9aadb6ee2778cae2187d6c2120583afeb80dff2e /dev-lua/lpeg
parentprofiles: add slotted-lua dev-lua/lpeg to package.mask (diff)
downloadgentoo-1a6dc03ce8e11606e794ea6d187771e18432153c.tar.gz
gentoo-1a6dc03ce8e11606e794ea6d187771e18432153c.tar.bz2
gentoo-1a6dc03ce8e11606e794ea6d187771e18432153c.zip
dev-lua/lpeg: revbump with slotted lua support
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-lua/lpeg')
-rw-r--r--dev-lua/lpeg/lpeg-1.0.2-r101.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-lua/lpeg/lpeg-1.0.2-r101.ebuild b/dev-lua/lpeg/lpeg-1.0.2-r101.ebuild
new file mode 100644
index 000000000000..10a6b94a1b47
--- /dev/null
+++ b/dev-lua/lpeg/lpeg-1.0.2-r101.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit lua flag-o-matic toolchain-funcs
+
+DESCRIPTION="Parsing Expression Grammars for Lua"
+HOMEPAGE="http://www.inf.puc-rio.br/~roberto/lpeg/"
+SRC_URI="http://www.inf.puc-rio.br/~roberto/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test debug doc"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+DOCS=( HISTORY )
+HTML_DOCS=( lpeg.html re.html )
+PATCHES=( "${FILESDIR}"/${PN}-1.0.2-makefile.patch )
+
+lua_src_prepare() {
+ if ! test -d "${S}.${ELUA}/" ; then
+ cp -ral "${S}/" "${S}.${ELUA}/" || die
+ fi
+}
+
+src_prepare() {
+ default
+ use debug && append-cflags -DLPEG_DEBUG
+ lua_foreach_impl lua_src_prepare
+}
+
+lua_src_compile() {
+ cd "${S}.${ELUA}/" || die
+ emake CC="$(tc-getCC)" \
+ LUADIR="$(lua_get_include_dir)"
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ cd "${S}.${ELUA}/" || die
+ ${ELUA} test.lua || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ cd "${S}.${ELUA}/" || die
+ local instdir
+ instdir="$(lua_get_cmod_dir)"
+ exeinto "${instdir#${EPREFIX}}"
+ doexe lpeg.so
+ instdir="$(lua_get_lmod_dir)"
+ insinto "${instdir#${EPREFIX}}"
+ doins re.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+ cd "${S}" || die
+ use doc && einstalldocs
+}