summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-03-14 01:51:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-03-14 01:51:25 +0100
commita58e9d9e453c2181fb076de2113cf14b2c7e2e5c (patch)
tree7626a3a7a1c5327d30a7eb153b43f292ae887797 /dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild
parentgames-simulation/openrct2: bump to version 0.3.3 (diff)
downloadgentoo-a58e9d9e453c2181fb076de2113cf14b2c7e2e5c.tar.gz
gentoo-a58e9d9e453c2181fb076de2113cf14b2c7e2e5c.tar.bz2
gentoo-a58e9d9e453c2181fb076de2113cf14b2c7e2e5c.zip
dev-lua/lua-argparse: bump to version 0.7.1
Upstream changed to luarocks now, but unfortunately, docs and tests have been removed. Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild')
-rw-r--r--dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild b/dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild
new file mode 100644
index 000000000000..669314b5265b
--- /dev/null
+++ b/dev-lua/lua-argparse/lua-argparse-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Feature-rich command line parser for Lua"
+HOMEPAGE="https://github.com/luarocks/argparse"
+SRC_URI="https://github.com/luarocks/${PN/lua-/}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN//lua-/}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins src/argparse.lua
+}
+
+src_install() {
+ default
+ lua_foreach_impl lua_src_install
+}